summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Winston <amynka@gentoo.org>2016-01-19 18:47:00 +0100
committerAmy Winston <amynka@gentoo.org>2016-01-19 18:48:11 +0100
commit0480aacf22c3c4d969b88a2a73ec98bd8eb38a1b (patch)
tree535015ea44255c0a9c18b5ebd550742a17bf2170 /media-libs/opencv
parentmedia-libs/opencv: 2.4.11 base migration (diff)
downloadgentoo-0480aacf22c3c4d969b88a2a73ec98bd8eb38a1b.tar.gz
gentoo-0480aacf22c3c4d969b88a2a73ec98bd8eb38a1b.tar.bz2
gentoo-0480aacf22c3c4d969b88a2a73ec98bd8eb38a1b.zip
media-libs/opencv: 3.0.0 base migration, use contrib repaired
Package-Manager: portage-2.2.24
Diffstat (limited to 'media-libs/opencv')
-rw-r--r--media-libs/opencv/opencv-3.0.0.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/media-libs/opencv/opencv-3.0.0.ebuild b/media-libs/opencv/opencv-3.0.0.ebuild
index 8ff2fd3c2dd0..98ea0df91bab 100644
--- a/media-libs/opencv/opencv-3.0.0.ebuild
+++ b/media-libs/opencv/opencv-3.0.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-inherit base toolchain-funcs cmake-utils python-single-r1 java-pkg-opt-2 java-ant-2
+inherit toolchain-funcs cmake-utils python-single-r1 java-pkg-opt-2 java-ant-2
DESCRIPTION="A collection of algorithms and sample code for various computer vision problems"
HOMEPAGE="http://opencv.org"
@@ -84,17 +84,13 @@ DEPEND="${RDEPEND}
java? ( >=virtual/jdk-1.6 )
"
-PATCHES=(
- "${FILESDIR}/${P}-gles.patch"
-)
-
pkg_setup() {
use python && python-single-r1_pkg_setup
java-pkg-opt-2_pkg_setup
}
src_prepare() {
- base_src_prepare
+ epatch "${FILESDIR}/${P}-gles.patch"
# remove bundled stuff
rm -rf 3rdparty
@@ -103,7 +99,9 @@ src_prepare() {
CMakeLists.txt cmake/*cmake || die
#removing broken sample bug #558104
- rm ../opencv_contrib-master/modules/ximgproc/samples/disparity_filtering.cpp
+ if use contrib; then
+ rm ../opencv_contrib-master/modules/ximgproc/samples/disparity_filtering.cpp
+ fi
java-pkg-opt-2_src_prepare
}