summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2019-01-17 09:59:50 +0100
committerAmy Liffey <amynka@gentoo.org>2019-01-17 19:12:05 +0100
commit510d7eb712901d372fba19bccc96e9d23855bae4 (patch)
tree9dd91ff7c32ddb31e49ba65a85ff85c83675a084 /media-libs/opencv
parentdev-db/postgresql: amd64 stable wrt bug #675572 (diff)
downloadgentoo-510d7eb712901d372fba19bccc96e9d23855bae4.tar.gz
gentoo-510d7eb712901d372fba19bccc96e9d23855bae4.tar.bz2
gentoo-510d7eb712901d372fba19bccc96e9d23855bae4.zip
media-libs/opencv: add missing build dep
Closes: https://bugs.gentoo.org/656576 Signed-off-by: Amy Liffey <amynka@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'media-libs/opencv')
-rw-r--r--media-libs/opencv/files/opencv-3.4.1-fix-build-with-va.patch26
-rw-r--r--media-libs/opencv/opencv-3.4.1-r5.ebuild4
2 files changed, 29 insertions, 1 deletions
diff --git a/media-libs/opencv/files/opencv-3.4.1-fix-build-with-va.patch b/media-libs/opencv/files/opencv-3.4.1-fix-build-with-va.patch
new file mode 100644
index 000000000000..813eb7e4ae65
--- /dev/null
+++ b/media-libs/opencv/files/opencv-3.4.1-fix-build-with-va.patch
@@ -0,0 +1,26 @@
+From 20f5fa8e3e880bc8b2e5156e9f25f7fb756ed8e4 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?S=C3=A9rgio=20M=2E=20Basto?= <sergio@serjux.com>
+Date: Wed, 28 Feb 2018 19:21:31 +0000
+Subject: [PATCH] Fix build with VA
+
+This commit readd ${VA_LIBRARIES} ${VA_INTEL_LIBRARIES}
+that was missed in commit 2200e13c7193e0fe9db4b9f7c4bee3a7ef043909
+
+ diff --git a/samples/va_intel/CMakeLists.txt b/samples/va_intel/CMakeLists.txt
+ - ocv_target_link_libraries(${the_target} ${OPENCV_LINKER_LIBS} ${OPENCV_VA_INTEL_SAMPLES_REQUIRED_DEPS} ${VA_LIBRARIES} ${VA_INTEL_LIBRARIES})
+ + ocv_target_link_libraries(${tgt} ${OPENCV_LINKER_LIBS} ${OPENCV_VA_INTEL_SAMPLES_REQUIRED_DEPS})
+---
+ samples/va_intel/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/samples/va_intel/CMakeLists.txt b/samples/va_intel/CMakeLists.txt
+index af51dd32061..04f2ea5fd40 100644
+--- a/samples/va_intel/CMakeLists.txt
++++ b/samples/va_intel/CMakeLists.txt
+@@ -17,5 +17,5 @@ ocv_include_modules_recurse(${OPENCV_VA_INTEL_SAMPLES_REQUIRED_DEPS})
+ file(GLOB all_samples RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.cpp)
+ foreach(sample_filename ${all_samples})
+ ocv_define_sample(tgt ${sample_filename} va_intel)
+- ocv_target_link_libraries(${tgt} ${OPENCV_LINKER_LIBS} ${OPENCV_VA_INTEL_SAMPLES_REQUIRED_DEPS})
++ ocv_target_link_libraries(${tgt} ${OPENCV_LINKER_LIBS} ${OPENCV_VA_INTEL_SAMPLES_REQUIRED_DEPS} ${VA_LIBRARIES} ${VA_INTEL_LIBRARIES})
+ endforeach()
diff --git a/media-libs/opencv/opencv-3.4.1-r5.ebuild b/media-libs/opencv/opencv-3.4.1-r5.ebuild
index 4b41ad5b7501..45086698e736 100644
--- a/media-libs/opencv/opencv-3.4.1-r5.ebuild
+++ b/media-libs/opencv/opencv-3.4.1-r5.ebuild
@@ -105,7 +105,8 @@ DEPEND="${RDEPEND}
virtual/pkgconfig[${MULTILIB_USEDEP}]
contrib_dnn? ( dev-libs/cereal )
eigen? ( dev-cpp/eigen:3 )
- java? ( >=virtual/jdk-1.6 )"
+ java? ( >=virtual/jdk-1.6 )
+ vaapi? ( x11-libs/libva )"
MULTILIB_WRAPPED_HEADERS=(
/usr/include/opencv2/cvconfig.h
@@ -231,6 +232,7 @@ PATCHES=(
"${FILESDIR}/${P}-python-lib-suffix-hack.patch"
"${FILESDIR}/${P}-cuda-add-relaxed-constexpr.patch"
"${FILESDIR}/${P}-remove-git-autodetect.patch"
+ "${FILESDIR}/${P}-fix-build-with-va.patch" # bug https://bugs.gentoo.org/656576
)
pkg_pretend() {