summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRandall Vasquez <ran.dall@icloud.com>2022-04-13 18:40:49 -0700
committerSam James <sam@gentoo.org>2022-04-14 07:50:12 +0100
commitf3a125d5b010c8fbdfb49061f75c3fd1fa821cae (patch)
treeddc9c07612753f08d86f6e5e7eab37f66c8d3554 /media-libs/opencv
parentsys-kernel/gentoo-kernel-bin: add 5.10.111 (diff)
downloadgentoo-f3a125d5b010c8fbdfb49061f75c3fd1fa821cae.tar.gz
gentoo-f3a125d5b010c8fbdfb49061f75c3fd1fa821cae.tar.bz2
gentoo-f3a125d5b010c8fbdfb49061f75c3fd1fa821cae.zip
media-libs/opencv: filter -O3 flags back down to -O2
Closes: https://bugs.gentoo.org/838274 Signed-off-by: Randall Vasquez <ran.dall@icloud.com> Closes: https://github.com/gentoo/gentoo/pull/25021 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/opencv')
-rw-r--r--media-libs/opencv/opencv-4.5.2-r3.ebuild7
-rw-r--r--media-libs/opencv/opencv-4.5.2-r5.ebuild7
-rw-r--r--media-libs/opencv/opencv-4.5.4.ebuild7
-rw-r--r--media-libs/opencv/opencv-4.5.5-r1.ebuild5
-rw-r--r--media-libs/opencv/opencv-4.5.5.ebuild7
5 files changed, 24 insertions, 9 deletions
diff --git a/media-libs/opencv/opencv-4.5.2-r3.ebuild b/media-libs/opencv/opencv-4.5.2-r3.ebuild
index 9b1bb3c11c7c..9b3f36c342d0 100644
--- a/media-libs/opencv/opencv-4.5.2-r3.ebuild
+++ b/media-libs/opencv/opencv-4.5.2-r3.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} )
CMAKE_ECLASS=cmake
-inherit java-pkg-opt-2 java-ant-2 cmake-multilib python-r1 toolchain-funcs
+inherit flag-o-matic java-pkg-opt-2 java-ant-2 cmake-multilib python-r1 toolchain-funcs
DESCRIPTION="A collection of algorithms and sample code for various computer vision problems"
HOMEPAGE="https://opencv.org"
@@ -295,6 +295,9 @@ pkg_setup() {
}
src_prepare() {
+ # https://bugs.gentoo.org/838274
+ replace-flags -O3 -O2
+
cmake_src_prepare
# remove bundled stuff
diff --git a/media-libs/opencv/opencv-4.5.2-r5.ebuild b/media-libs/opencv/opencv-4.5.2-r5.ebuild
index 21f9624b9049..2b66d2c57956 100644
--- a/media-libs/opencv/opencv-4.5.2-r5.ebuild
+++ b/media-libs/opencv/opencv-4.5.2-r5.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{7,8,9,10} )
CMAKE_ECLASS=cmake
-inherit java-pkg-opt-2 java-ant-2 cmake-multilib python-r1 toolchain-funcs
+inherit flag-o-matic java-pkg-opt-2 java-ant-2 cmake-multilib python-r1 toolchain-funcs
DESCRIPTION="A collection of algorithms and sample code for various computer vision problems"
HOMEPAGE="https://opencv.org"
@@ -296,6 +296,9 @@ pkg_setup() {
}
src_prepare() {
+ # https://bugs.gentoo.org/838274
+ replace-flags -O3 -O2
+
cmake_src_prepare
# remove bundled stuff
diff --git a/media-libs/opencv/opencv-4.5.4.ebuild b/media-libs/opencv/opencv-4.5.4.ebuild
index d294809c1d6a..24070fe0c2e4 100644
--- a/media-libs/opencv/opencv-4.5.4.ebuild
+++ b/media-libs/opencv/opencv-4.5.4.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{8..10} )
CMAKE_ECLASS=cmake
-inherit java-pkg-opt-2 java-ant-2 cmake-multilib python-r1 toolchain-funcs
+inherit flag-o-matic java-pkg-opt-2 java-ant-2 cmake-multilib python-r1 toolchain-funcs
DESCRIPTION="A collection of algorithms and sample code for various computer vision problems"
HOMEPAGE="https://opencv.org"
@@ -307,6 +307,9 @@ pkg_setup() {
}
src_prepare() {
+ # https://bugs.gentoo.org/838274
+ replace-flags -O3 -O2
+
cmake_src_prepare
# remove bundled stuff
diff --git a/media-libs/opencv/opencv-4.5.5-r1.ebuild b/media-libs/opencv/opencv-4.5.5-r1.ebuild
index 98288510a586..e3d2e5a3efbe 100644
--- a/media-libs/opencv/opencv-4.5.5-r1.ebuild
+++ b/media-libs/opencv/opencv-4.5.5-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{8..10} )
CMAKE_ECLASS=cmake
-inherit java-pkg-opt-2 java-ant-2 cmake-multilib python-r1 toolchain-funcs
+inherit flag-o-matic java-pkg-opt-2 java-ant-2 cmake-multilib python-r1 toolchain-funcs
DESCRIPTION="A collection of algorithms and sample code for various computer vision problems"
HOMEPAGE="https://opencv.org"
@@ -303,6 +303,9 @@ pkg_setup() {
}
src_prepare() {
+ # https://bugs.gentoo.org/838274
+ replace-flags -O3 -O2
+
cmake_src_prepare
# remove bundled stuff
diff --git a/media-libs/opencv/opencv-4.5.5.ebuild b/media-libs/opencv/opencv-4.5.5.ebuild
index cc9da840a605..7eddbcd042ce 100644
--- a/media-libs/opencv/opencv-4.5.5.ebuild
+++ b/media-libs/opencv/opencv-4.5.5.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{8..10} )
CMAKE_ECLASS=cmake
-inherit java-pkg-opt-2 java-ant-2 cmake-multilib python-r1 toolchain-funcs
+inherit flag-o-matic java-pkg-opt-2 java-ant-2 cmake-multilib python-r1 toolchain-funcs
DESCRIPTION="A collection of algorithms and sample code for various computer vision problems"
HOMEPAGE="https://opencv.org"
@@ -303,6 +303,9 @@ pkg_setup() {
}
src_prepare() {
+ # https://bugs.gentoo.org/838274
+ replace-flags -O3 -O2
+
cmake_src_prepare
# remove bundled stuff