summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-07-16 23:11:40 +0100
committerMarek Szuba <marecki@gentoo.org>2021-07-16 23:16:27 +0100
commitab742fb45261c9c6214f31e08cdb35eee83efe2e (patch)
treeedf630de63c6bcb27febe5a830851cbd57fba15f /media-libs/openexr
parentapp-arch/libarchive: enable threads unconditionally (diff)
downloadgentoo-ab742fb45261c9c6214f31e08cdb35eee83efe2e.tar.gz
gentoo-ab742fb45261c9c6214f31e08cdb35eee83efe2e.tar.bz2
gentoo-ab742fb45261c9c6214f31e08cdb35eee83efe2e.zip
media-libs/openexr: keyword 2.5.7 for ~riscv
On a BeagleV Starlight, IlmImfTest times out by default - but with the time-out threshold increased from the default 1500 s to 1.5 h, tests pass. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'media-libs/openexr')
-rw-r--r--media-libs/openexr/files/openexr-2.5.7-0002-increase-IlmImfTest-timeout.patch13
-rw-r--r--media-libs/openexr/openexr-2.5.7.ebuild8
2 files changed, 20 insertions, 1 deletions
diff --git a/media-libs/openexr/files/openexr-2.5.7-0002-increase-IlmImfTest-timeout.patch b/media-libs/openexr/files/openexr-2.5.7-0002-increase-IlmImfTest-timeout.patch
new file mode 100644
index 000000000000..ef71bc0e6871
--- /dev/null
+++ b/media-libs/openexr/files/openexr-2.5.7-0002-increase-IlmImfTest-timeout.patch
@@ -0,0 +1,13 @@
+This consists of A LOT of individual tests and on some hardware
+(e.g. the RISC-V board BeagleV Starlight) the default test time-out
+of 1500 seconds is greatly insufficient. On said BeagleV OpenEXR.IlmImf
+takes almost 4800 s even on an otherwise idle system so let's add a bit
+of margin and set the time-out of this test to 1.5 hours.
+
+--- a/IlmImfTest/CMakeLists.txt 2021-06-15 00:15:14.000000000 +0000
++++ b/IlmImfTest/CMakeLists.txt 2021-07-16 16:51:20.600435829 +0000
+@@ -73,3 +73,4 @@
+ target_compile_definitions(IlmImfTest PRIVATE OPENEXR_DLL)
+ endif()
+ add_test(NAME OpenEXR.IlmImf COMMAND $<TARGET_FILE:IlmImfTest>)
++set_tests_properties(OpenEXR.IlmImf PROPERTIES TIMEOUT 5400)
diff --git a/media-libs/openexr/openexr-2.5.7.ebuild b/media-libs/openexr/openexr-2.5.7.ebuild
index d94729d81f27..8a5f1c968b22 100644
--- a/media-libs/openexr/openexr-2.5.7.ebuild
+++ b/media-libs/openexr/openexr-2.5.7.ebuild
@@ -13,7 +13,7 @@ S="${WORKDIR}/${P}/OpenEXR"
LICENSE="BSD"
SLOT="0/25" # based on SONAME
-KEYWORDS="amd64 ~arm arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+KEYWORDS="amd64 ~arm arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
IUSE="cpu_flags_x86_avx doc examples static-libs utils test"
RESTRICT="!test? ( test )"
@@ -36,6 +36,12 @@ src_prepare() {
eapply "${FILESDIR}/${PN}-2.5.2-0001-IlmImfTest-main.cpp-disable-tests.patch"
fi
+ # Technically this doesn't disable anything, it just gives this test time to complete.
+ # Could probably be applied unconditionally but will leave this to the maintainers.
+ if use riscv; then
+ eapply "${FILESDIR}/${P}-0002-increase-IlmImfTest-timeout.patch"
+ fi
+
if use sparc; then
eapply "${FILESDIR}/${P}-0001-disable-testRgba-on-sparc.patch"
fi