summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <jchelmert3@posteo.net>2020-07-30 02:01:27 -0500
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-23 19:12:57 +0100
commit3ba62aa6a060734ae14a0e6f978c584746635248 (patch)
treecf3f9641dcfaf871302f91caa0735e9fb53eba53 /media-libs/openjpeg/openjpeg-1.5.2-r1.ebuild
parentmedia-gfx/xpaint: Drop 2.10.2 (r0) (diff)
downloadgentoo-3ba62aa6a060734ae14a0e6f978c584746635248.tar.gz
gentoo-3ba62aa6a060734ae14a0e6f978c584746635248.tar.bz2
gentoo-3ba62aa6a060734ae14a0e6f978c584746635248.zip
media-libs/openjpeg: Security cleanup (drop :0)
Bug: https://bugs.gentoo.org/711260 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: John Helmert III <jchelmert3@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/16909 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/openjpeg/openjpeg-1.5.2-r1.ebuild')
-rw-r--r--media-libs/openjpeg/openjpeg-1.5.2-r1.ebuild77
1 files changed, 0 insertions, 77 deletions
diff --git a/media-libs/openjpeg/openjpeg-1.5.2-r1.ebuild b/media-libs/openjpeg/openjpeg-1.5.2-r1.ebuild
deleted file mode 100644
index 59ab4ced81a1..000000000000
--- a/media-libs/openjpeg/openjpeg-1.5.2-r1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-multilib
-
-DESCRIPTION="An open-source JPEG 2000 library"
-HOMEPAGE="https://www.openjpeg.org"
-SRC_URI="mirror://sourceforge/${PN}.mirror/${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0/5" # based on SONAME
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc static-libs test"
-
-RDEPEND="
- media-libs/lcms:2=
- media-libs/libpng:0=
- media-libs/tiff:0=
- sys-libs/zlib:="
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
-
-DOCS=( AUTHORS CHANGES NEWS README THANKS )
-
-RESTRICT="test" # bug 409263
-
-src_prepare() {
- cmake-utils_src_prepare
- # Stop installing LICENSE file, and install CHANGES from DOCS instead:
- sed -i -e '/INSTALL.*FILES.*DESTINATION.*OPENJPEG_INSTALL_DOC_DIR/d' CMakeLists.txt || die
-}
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DOPENJPEG_INSTALL_LIB_DIR="$(get_libdir)"
- -DBUILD_TESTING=$(usex test)
- -DBUILD_DOC=$(multilib_native_usex doc ON OFF)
- -DBUILD_CODEC=$(multilib_is_native_abi && echo ON || echo OFF)
- )
-
- cmake-utils_src_configure
-
- if use static-libs; then
- mycmakeargs=(
- -DOPENJPEG_INSTALL_LIB_DIR="$(get_libdir)"
- -DBUILD_TESTING=$(usex test)
- -DBUILD_SHARED_LIBS=OFF
- -DBUILD_CODEC=OFF
- )
- BUILD_DIR=${BUILD_DIR}_static cmake-utils_src_configure
- fi
-}
-
-multilib_src_compile() {
- cmake-utils_src_compile
-
- if use static-libs; then
- BUILD_DIR=${BUILD_DIR}_static cmake-utils_src_compile
- fi
-}
-
-multilib_src_install() {
- if use static-libs; then
- BUILD_DIR=${BUILD_DIR}_static cmake-utils_src_install
- fi
-
- cmake-utils_src_install
-
- dosym openjpeg-1.5/openjpeg.h /usr/include/openjpeg.h
- dosym libopenjpeg1.pc /usr/$(get_libdir)/pkgconfig/libopenjpeg.pc
-
- if use doc && multilib_is_native_abi; then
- dodoc -r doc/html
- fi
-}