summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-12-06 22:50:13 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-12-06 22:54:05 +0100
commit1a99bc412b0ce8ee049bb0613230325cfd8055f2 (patch)
tree9539e3789df1622dff83205979a243d7aec48cc1 /media-libs/openmoiv/openmoiv-1.0.3a.ebuild
parentsys-block/perccli: new package (diff)
downloadgentoo-1a99bc412b0ce8ee049bb0613230325cfd8055f2.tar.gz
gentoo-1a99bc412b0ce8ee049bb0613230325cfd8055f2.tar.bz2
gentoo-1a99bc412b0ce8ee049bb0613230325cfd8055f2.zip
media-libs/openmoiv: New package. Imported from sci overlay.
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'media-libs/openmoiv/openmoiv-1.0.3a.ebuild')
-rw-r--r--media-libs/openmoiv/openmoiv-1.0.3a.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-libs/openmoiv/openmoiv-1.0.3a.ebuild b/media-libs/openmoiv/openmoiv-1.0.3a.ebuild
new file mode 100644
index 000000000000..7bf763c6cd8f
--- /dev/null
+++ b/media-libs/openmoiv/openmoiv-1.0.3a.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Object-oriented 3D toolkit for rendering and interaction of chemical systems"
+HOMEPAGE="http://www.tecn.upf.es/openMOIV/"
+SRC_URI="http://www.tecn.upf.es/openMOIV/download/1.0.3/OpenMOIV.src.${PV}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+RDEPEND="media-libs/coin"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/OpenMOIV.src.${PV/a//}"
+
+src_prepare() {
+ default
+ sed \
+ -e 's:$ENV{OIV_DIR}/include:/usr/include/coin:g' \
+ -i CMakeLists.txt || die
+}
+
+src_configure() {
+ mycmakeargs=(
+ -Dshared:int=1
+ -Dcoin:int=1
+ -Dsys_fonts:int=1
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ dolib.so "${BUILD_DIR}"/libChemKit2.so
+
+ insinto /usr/include
+ doins -r "${S}"/include/ChemKit2
+}