summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Scruggs <j.scruggs@gmail.com>2017-12-24 18:37:08 +0000
committerDavid Seifert <soap@gentoo.org>2017-12-24 23:15:56 +0100
commit02baca534283f0b8bfda69c603033418726a34b2 (patch)
tree9c6e2482d4e97de787f972c505e0a336a42be31e /media-libs/opensubdiv/opensubdiv-3.3.0.ebuild
parentwww-client/chromium: dev channel bump (65.0.3298.3) (diff)
downloadgentoo-02baca534283f0b8bfda69c603033418726a34b2.tar.gz
gentoo-02baca534283f0b8bfda69c603033418726a34b2.tar.bz2
gentoo-02baca534283f0b8bfda69c603033418726a34b2.zip
media-libs/opensubdiv: Add CUDA 9 compatibility patch
Closes: https://bugs.gentoo.org/641242 Closes: https://github.com/gentoo/gentoo/pull/6624
Diffstat (limited to 'media-libs/opensubdiv/opensubdiv-3.3.0.ebuild')
-rw-r--r--media-libs/opensubdiv/opensubdiv-3.3.0.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/media-libs/opensubdiv/opensubdiv-3.3.0.ebuild b/media-libs/opensubdiv/opensubdiv-3.3.0.ebuild
index 1c1abebee365..a85444ac261c 100644
--- a/media-libs/opensubdiv/opensubdiv-3.3.0.ebuild
+++ b/media-libs/opensubdiv/opensubdiv-3.3.0.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/PixarAnimationStudios/OpenSubdiv/archive/v${MY_PV}.t
LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="cuda doc opencl openmp ptex tbb"
+IUSE="cuda doc examples opencl openmp ptex tbb tutorials"
RDEPEND="media-libs/glew:=
media-libs/glfw:=
@@ -32,6 +32,7 @@ S="${WORKDIR}/OpenSubdiv-${MY_PV}"
PATCHES=(
"${FILESDIR}/${P}-fix-quotes.patch"
"${FILESDIR}/${P}-use-gnuinstalldirs.patch"
+ "${FILESDIR}/${P}-add-CUDA9-compatibility.patch"
)
pkg_pretend() {
@@ -53,8 +54,8 @@ src_configure() {
-DNO_OPENCL=$(usex !opencl)
-DNO_CUDA=$(usex !cuda)
-DNO_REGRESSION=1 # They don't work with certain settings
- -DNO_EXAMPLES=1 # Not needed.
- -DNO_TUTORIALS=1 # They install illegally. Need to find a better solution.
+ -DNO_EXAMPLES=$(usex !examples)
+ -DNO_TUTORIALS=$(usex !tutorials)
-DGLEW_LOCATION="${EPREFIX}/usr/$(get_libdir)"
-DGLFW_LOCATION="${EPREFIX}/usr/$(get_libdir)"
-DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"