summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/opus
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/opus')
-rw-r--r--media-libs/opus/Manifest2
-rw-r--r--media-libs/opus/files/1.1-fix-configure.ac-shell-bug.patch14
-rw-r--r--media-libs/opus/metadata.xml8
-rw-r--r--media-libs/opus/opus-1.0.2-r2.ebuild42
-rw-r--r--media-libs/opus/opus-1.1.ebuild35
5 files changed, 101 insertions, 0 deletions
diff --git a/media-libs/opus/Manifest b/media-libs/opus/Manifest
new file mode 100644
index 000000000000..d0940c4d1b3e
--- /dev/null
+++ b/media-libs/opus/Manifest
@@ -0,0 +1,2 @@
+DIST opus-1.0.2.tar.gz 777306 SHA256 da615edbee5d019c1833071d69a4782c19f178cf9ca1401375036ecef25cd78a SHA512 73f089ac9c6fcf6adea6c862f6ac0e56712473f9dcaec3aec444a988ded1abcec7fa69da286af38500182dfaf96ba0b6ca52431c39ed08f2aa1caf84ffd43b39 WHIRLPOOL f953cc7f8bd4332524ee403e7dbd9647a29d324a30ef820e5b96a316366ab0a168f55e36a0ab5b239afe7f547874eb28aff1529e38774c1a880da1b7ce7daa86
+DIST opus-1.1.tar.gz 850208 SHA256 b9727015a58affcf3db527322bf8c4d2fcf39f5f6b8f15dbceca20206cbe1d95 SHA512 b603efe66d65ef38dbcd0d2bbf213a1d15fa456aee00eca73e99abe4ec78668ed82e661ca7a69e9af4e0bc39e1aa76c4151b7f9840ff621ddcfd69f596cf2ba9 WHIRLPOOL 9d53e57d0c99b7e5e330822808f5b79e19bb3fbbffb9054e3d1d421b42fd70463d5fc39517eff1169d218bad8ab2440162c334ace013ffba846cbcfb57206201
diff --git a/media-libs/opus/files/1.1-fix-configure.ac-shell-bug.patch b/media-libs/opus/files/1.1-fix-configure.ac-shell-bug.patch
new file mode 100644
index 000000000000..e35452436259
--- /dev/null
+++ b/media-libs/opus/files/1.1-fix-configure.ac-shell-bug.patch
@@ -0,0 +1,14 @@
+--- opus-1.1.orig/configure.ac
++++ opus-1.1/configure.ac
+@@ -333,9 +333,9 @@ AS_IF([test x"${enable_asm}" = x"yes"],[
+
+ AM_CONDITIONAL([CPU_ARM], [test "$cpu_arm" = "yes"])
+ AM_CONDITIONAL([OPUS_ARM_INLINE_ASM],
+- [test x"${inline_optimization:0:3}" = x"ARM"])
++ [test x"${inline_optimization%% *}" = x"ARM"])
+ AM_CONDITIONAL([OPUS_ARM_EXTERNAL_ASM],
+- [test x"${asm_optimization:0:3}" = x"ARM"])
++ [test x"${asm_optimization%% *}" = x"ARM"])
+
+ AS_IF([test x"$enable_rtcd" = x"yes"],[
+ AS_IF([test x"$rtcd_support" != x"no"],[
diff --git a/media-libs/opus/metadata.xml b/media-libs/opus/metadata.xml
new file mode 100644
index 000000000000..82bdb149a9cc
--- /dev/null
+++ b/media-libs/opus/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <use>
+ <flag name="custom-modes">Build with custom-modes.</flag>
+ </use>
+</pkgmetadata>
diff --git a/media-libs/opus/opus-1.0.2-r2.ebuild b/media-libs/opus/opus-1.0.2-r2.ebuild
new file mode 100644
index 000000000000..ac82a24608ea
--- /dev/null
+++ b/media-libs/opus/opus-1.0.2-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == *9999 ]] ; then
+ SCM="git-2"
+ EGIT_REPO_URI="git://git.opus-codec.org/opus.git"
+ AUTOTOOLS_AUTORECONF="1"
+fi
+
+inherit autotools-multilib ${SCM}
+
+MY_P=${P/_/-}
+DESCRIPTION="Open versatile codec designed for interactive speech and audio transmission over the internet"
+HOMEPAGE="http://opus-codec.org/"
+SRC_URI="http://downloads.xiph.org/releases/opus/${P}.tar.gz"
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
+ SRC_URI="http://dev.gentoo.org/~lu_zero/${PN}/${P}.tar.xz"
+else # Official release
+ SRC_URI="http://downloads.xiph.org/releases/${PN}/${MY_P}.tar.gz"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd"
+IUSE="custom-modes doc static-libs"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable custom-modes)
+ $(use_enable doc)
+ )
+ autotools-multilib_src_configure
+}
diff --git a/media-libs/opus/opus-1.1.ebuild b/media-libs/opus/opus-1.1.ebuild
new file mode 100644
index 000000000000..205c25b4ba93
--- /dev/null
+++ b/media-libs/opus/opus-1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+AUTOTOOLS_AUTORECONF="1"
+inherit autotools-multilib
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-2
+ EGIT_REPO_URI="git://git.opus-codec.org/opus.git"
+else
+ SRC_URI="http://downloads.xiph.org/releases/${PN}/${P}.tar.gz"
+ KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd"
+fi
+
+DESCRIPTION="Open versatile codec designed for interactive speech and audio transmission over the internet"
+HOMEPAGE="http://opus-codec.org/"
+SRC_URI="http://downloads.xiph.org/releases/opus/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="custom-modes doc static-libs"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+PATCHES=( "${FILESDIR}/1.1-fix-configure.ac-shell-bug.patch" ) # bug 510918
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable custom-modes)
+ $(use_enable doc)
+ )
+ autotools-multilib_src_configure
+}