summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-10-05 10:48:28 +0200
committerJulian Ospald <hasufell@gentoo.org>2015-10-05 10:48:28 +0200
commite27dcccccd49336d661876bba52525389c157b3d (patch)
treea0f9263c1c3e3e68174f189dd0a95b03ebed8640 /media-libs/opusfile/opusfile-0.6-r1.ebuild
parentdev-libs/poco: add libressl support (diff)
downloadgentoo-e27dcccccd49336d661876bba52525389c157b3d.tar.gz
gentoo-e27dcccccd49336d661876bba52525389c157b3d.tar.bz2
gentoo-e27dcccccd49336d661876bba52525389c157b3d.zip
media-libs/opusfile: add libressl support
Diffstat (limited to 'media-libs/opusfile/opusfile-0.6-r1.ebuild')
-rw-r--r--media-libs/opusfile/opusfile-0.6-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-libs/opusfile/opusfile-0.6-r1.ebuild b/media-libs/opusfile/opusfile-0.6-r1.ebuild
new file mode 100644
index 000000000000..719011df8f5f
--- /dev/null
+++ b/media-libs/opusfile/opusfile-0.6-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A high-level decoding and seeking API for .opus files"
+HOMEPAGE="http://www.opus-codec.org/"
+SRC_URI="http://downloads.xiph.org/releases/opus/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc fixed-point +float +http libressl static-libs"
+
+RDEPEND="media-libs/libogg
+ media-libs/opus
+ http? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+REQUIRED_USE="^^ ( fixed-point float )"
+
+src_configure() {
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable doc) \
+ $(use_enable fixed-point)\
+ $(use_enable float) \
+ $(use_enable http) \
+ $(use_enable static-libs static)
+}