summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-08-07 09:41:50 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-08-07 09:53:29 +0200
commit67a7634e24dc48ecd552550ae5ce9fe290a81e6a (patch)
treea170c61f695143951009c547fbaf4099f09ca1cd /media-libs/opusfile/opusfile-0.9.ebuild
parentapp-admin/logsentry: eapi bump to 6 (diff)
downloadgentoo-67a7634e24dc48ecd552550ae5ce9fe290a81e6a.tar.gz
gentoo-67a7634e24dc48ecd552550ae5ce9fe290a81e6a.tar.bz2
gentoo-67a7634e24dc48ecd552550ae5ce9fe290a81e6a.zip
media-libs/opusfile: Bump to version 0.9
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'media-libs/opusfile/opusfile-0.9.ebuild')
-rw-r--r--media-libs/opusfile/opusfile-0.9.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/opusfile/opusfile-0.9.ebuild b/media-libs/opusfile/opusfile-0.9.ebuild
new file mode 100644
index 000000000000..d7b26eeef53f
--- /dev/null
+++ b/media-libs/opusfile/opusfile-0.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A high-level decoding and seeking API for .opus files"
+HOMEPAGE="http://www.opus-codec.org/"
+SRC_URI="http://downloads.xiph.org/releases/opus/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc fixed-point +float +http libressl static-libs"
+
+RDEPEND="media-libs/libogg
+ media-libs/opus
+ http? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+REQUIRED_USE="^^ ( fixed-point float )"
+
+src_configure() {
+ local myeconfargs=(
+ --docdir=/usr/share/doc/${PF}
+ $(use_enable doc)
+ $(use_enable fixed-point)\
+ $(use_enable float)
+ $(use_enable http)
+ $(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
+}