summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-27 00:42:26 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-27 00:51:01 +0100
commit26db062e7b8df1334a8deb33edb799cad97cff2b (patch)
treeeb3cfc23c4254ab801b2e19ace012338a528b41d /media-libs/oyranos/files
parentdev-python/pipfile: arm64 keyworded (bug #702190) (diff)
downloadgentoo-26db062e7b8df1334a8deb33edb799cad97cff2b.tar.gz
gentoo-26db062e7b8df1334a8deb33edb799cad97cff2b.tar.bz2
gentoo-26db062e7b8df1334a8deb33edb799cad97cff2b.zip
media-libs/oyranos: Fix mesa build error, drop multilib remnant, use xdg
Closes: https://bugs.gentoo.org/671996 Closes: https://bugs.gentoo.org/672004 Closes: https://bugs.gentoo.org/672006 Closes: https://bugs.gentoo.org/680324 Closes: https://bugs.gentoo.org/689686 Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/oyranos/files')
-rw-r--r--media-libs/oyranos/files/oyranos-0.9.6-mesa-18.3.1.patch24
-rw-r--r--media-libs/oyranos/files/oyranos-0.9.6-underlinking.patch16
2 files changed, 40 insertions, 0 deletions
diff --git a/media-libs/oyranos/files/oyranos-0.9.6-mesa-18.3.1.patch b/media-libs/oyranos/files/oyranos-0.9.6-mesa-18.3.1.patch
new file mode 100644
index 000000000000..83ed82a5629a
--- /dev/null
+++ b/media-libs/oyranos/files/oyranos-0.9.6-mesa-18.3.1.patch
@@ -0,0 +1,24 @@
+From ac7bdc35ea376f938ad223b0156a04a2af6d2eff Mon Sep 17 00:00:00 2001
+From: Kai-Uwe Behrmann <ku.b@gmx.de>
+Date: Fri, 28 Dec 2018 00:14:24 +0100
+Subject: [PATCH] * [exmpl]: update GLee.h to Mesa-18.3.1
+
+the include guards of system files changed
+---
+ src/examples/image_display/GLee.h | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/examples/image_display/GLee.h b/src/examples/image_display/GLee.h
+index 2edca003..01b19c68 100644
+--- a/src/examples/image_display/GLee.h
++++ b/src/examples/image_display/GLee.h
+@@ -61,7 +61,9 @@
+ #include <OpenGL/gl.h>
+ #else // GLX
+ #define __glext_h_ /* prevent glext.h from being included */
++ #define __gl_glext_h_
+ #define __glxext_h_ /* prevent glxext.h from being included */
++ #define __glx_glxext_h_
+ #define GLX_GLXEXT_PROTOTYPES
+ #include <GL/gl.h>
+ #include <GL/glx.h>
diff --git a/media-libs/oyranos/files/oyranos-0.9.6-underlinking.patch b/media-libs/oyranos/files/oyranos-0.9.6-underlinking.patch
new file mode 100644
index 000000000000..b25a36cf79e9
--- /dev/null
+++ b/media-libs/oyranos/files/oyranos-0.9.6-underlinking.patch
@@ -0,0 +1,16 @@
+Index: oyranos-0.9.6/src/modules/color/modules/CMakeLists.txt
+===================================================================
+--- oyranos-0.9.6.orig/src/modules/color/modules/CMakeLists.txt
++++ oyranos-0.9.6/src/modules/color/modules/CMakeLists.txt
+@@ -74,9 +74,9 @@ SET( OY_MODULE oydi )
+ SET( OY_MODULE_LIB ${PACKAGE_NAME}_${OY_MODULE}${OY_MODULE_NAME} )
+ ADD_LIBRARY( ${OY_MODULE_LIB}
+ SHARED ${PACKAGE_NAME}_cmm_${OY_MODULE}.c )
+-TARGET_LINK_LIBRARIES ( ${OY_MODULE_LIB} ${PROJECT_NAME} ${EXTRA_LIBS} ${XCM_LIBRARIES} ${XFIXES_LIBRARIES} )
++TARGET_LINK_LIBRARIES ( ${OY_MODULE_LIB} ${PROJECT_NAME} ${EXTRA_LIBS} ${XCM_LIBRARIES} ${XFIXES_LIBRARIES} ${X11_LIBRARIES} )
+ INSTALL (TARGETS ${OY_MODULE_LIB} DESTINATION ${CMAKE_INSTALL_LIBDIR}/${OY_CMMSUBPATH})
+-SET( OY_MODULE_LIBRARIES ${OY_MODULE_LIBRARIES} ${XCM_LIBRARIES} ${XFIXES_LIBRARIES} )
++SET( OY_MODULE_LIBRARIES ${OY_MODULE_LIBRARIES} ${XCM_LIBRARIES} ${XFIXES_LIBRARIES} ${X11_LIBRARIES} )
+
+ SET( OY_MODULE oyra )
+ SET( OY_MODULE_LIB ${PACKAGE_NAME}_${OY_MODULE}${OY_MODULE_NAME} )