summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-08-27 21:16:22 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-08-27 21:58:23 +0200
commit2b40255c1e009b6072dabe06dd24d5a4a81e1ba8 (patch)
treebc5bb15d3af82fcae4b43b8463e76fc245e40ff2 /media-libs/phonon-gstreamer/phonon-gstreamer-4.10.0.ebuild
parentmedia-libs/phonon: Drop 4.10.3 (diff)
downloadgentoo-2b40255c1e009b6072dabe06dd24d5a4a81e1ba8.tar.gz
gentoo-2b40255c1e009b6072dabe06dd24d5a4a81e1ba8.tar.bz2
gentoo-2b40255c1e009b6072dabe06dd24d5a4a81e1ba8.zip
media-libs/phonon-gstreamer: 4.10.0 version bump
Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/phonon-gstreamer/phonon-gstreamer-4.10.0.ebuild')
-rw-r--r--media-libs/phonon-gstreamer/phonon-gstreamer-4.10.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-libs/phonon-gstreamer/phonon-gstreamer-4.10.0.ebuild b/media-libs/phonon-gstreamer/phonon-gstreamer-4.10.0.ebuild
new file mode 100644
index 000000000000..34230a07d8eb
--- /dev/null
+++ b/media-libs/phonon-gstreamer/phonon-gstreamer-4.10.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="phonon-backend-gstreamer"
+inherit kde5
+
+DESCRIPTION="GStreamer backend for the Phonon multimedia library"
+HOMEPAGE="https://phonon.kde.org/"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/phonon/${MY_PN}/${PV}/${MY_PN}-${PV}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-fbsd"
+fi
+
+LICENSE="LGPL-2.1+ || ( LGPL-2.1 LGPL-3 )"
+SLOT="0"
+IUSE="alsa debug +network"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/libxml2:2
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-libs/gst-plugins-base:1.0
+ media-libs/gstreamer:1.0
+ >=media-libs/phonon-4.10.60
+ media-plugins/gst-plugins-meta:1.0[alsa?,ogg,vorbis]
+ virtual/opengl
+"
+RDEPEND="${DEPEND}
+ network? ( media-plugins/gst-plugins-soup:1.0 )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"