summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-01-23 13:35:22 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2016-01-23 13:37:04 -0500
commitc2c3350ada353ca2c523210909a4fea07fcc5a10 (patch)
treeb9f354ff68ccb4d166dcc5ea2dbdc1da7e2e31fa /media-libs/plib/plib-1.8.5-r1.ebuild
parentsys-kernel/gentoo-sources: Fix header (diff)
downloadgentoo-c2c3350ada353ca2c523210909a4fea07fcc5a10.tar.gz
gentoo-c2c3350ada353ca2c523210909a4fea07fcc5a10.tar.bz2
gentoo-c2c3350ada353ca2c523210909a4fea07fcc5a10.zip
media-libs/plib: add patches from Debian (bug #395553 and bug #440762)
Package-Manager: portage-2.2.26
Diffstat (limited to 'media-libs/plib/plib-1.8.5-r1.ebuild')
-rw-r--r--media-libs/plib/plib-1.8.5-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-libs/plib/plib-1.8.5-r1.ebuild b/media-libs/plib/plib-1.8.5-r1.ebuild
new file mode 100644
index 000000000000..f9045ab6a2a3
--- /dev/null
+++ b/media-libs/plib/plib-1.8.5-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit flag-o-matic eutils autotools
+
+DESCRIPTION="multimedia library used by many games"
+HOMEPAGE="http://plib.sourceforge.net/"
+SRC_URI="http://plib.sourceforge.net/dist/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+
+DEPEND="virtual/opengl"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-X11.patch \
+ "${FILESDIR}"/${P}-CVE-2011-4552.patch \
+ "${FILESDIR}"/${P}-CVE-2011-4620.patch
+
+ eautoreconf
+ # Since plib only provides static libraries, force
+ # building as PIC or plib is useless to amd64/etc...
+ append-flags -fPIC
+}
+
+src_install() {
+ default
+ dodoc AUTHORS ChangeLog KNOWN_BUGS NOTICE README* TODO*
+}