summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/plib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/plib')
-rw-r--r--media-libs/plib/Manifest1
-rw-r--r--media-libs/plib/files/plib-1.8.5-X11.patch11
-rw-r--r--media-libs/plib/metadata.xml5
-rw-r--r--media-libs/plib/plib-1.8.5.ebuild30
4 files changed, 47 insertions, 0 deletions
diff --git a/media-libs/plib/Manifest b/media-libs/plib/Manifest
new file mode 100644
index 000000000000..47b51fac83cf
--- /dev/null
+++ b/media-libs/plib/Manifest
@@ -0,0 +1 @@
+DIST plib-1.8.5.tar.gz 779133 SHA256 485b22bf6fdc0da067e34ead5e26f002b76326f6371e2ae006415dea6a380a32 SHA512 17154cc77243fe576c2bcbcb0285b98aef1a0634658f5473e95fe0ac8fa3ed477dbe5620e44ccf0b7cc616f812af0cd44d6fcbba0c563180d3b61c9d6f158e1d WHIRLPOOL 98ccfc78eff5e27539a4d046dbb761aaed6a53410026b1ae19cb3681a691f644000ad775e0b0211e45b582a8bb06c9d3cfc33849a6e02309b840d2db1f736b32
diff --git a/media-libs/plib/files/plib-1.8.5-X11.patch b/media-libs/plib/files/plib-1.8.5-X11.patch
new file mode 100644
index 000000000000..86bccc31c0e6
--- /dev/null
+++ b/media-libs/plib/files/plib-1.8.5-X11.patch
@@ -0,0 +1,11 @@
+--- configure.in.old 2014-10-14 12:23:00.422971952 +0200
++++ configure.in 2014-10-14 12:23:24.806746868 +0200
+@@ -276,7 +276,7 @@
+
+ LDFLAGS="$LDFLAGS $X_LIBS"
+
+- LIBS="$LIBS $X_PRE_LIBS -lXi -lXmu -lXext -lX11 $X_EXTRA_LIBS -lm"
++ LIBS="$LIBS $X_PRE_LIBS -lX11 $X_EXTRA_LIBS -lm"
+
+ dnl =========================================================
+ dnl if test "x$x_includes" != "x"; then
diff --git a/media-libs/plib/metadata.xml b/media-libs/plib/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/media-libs/plib/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/media-libs/plib/plib-1.8.5.ebuild b/media-libs/plib/plib-1.8.5.ebuild
new file mode 100644
index 000000000000..09e2d48d8afd
--- /dev/null
+++ b/media-libs/plib/plib-1.8.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit flag-o-matic eutils autotools
+
+DESCRIPTION="multimedia library used by many games"
+HOMEPAGE="http://plib.sourceforge.net/"
+SRC_URI="http://plib.sourceforge.net/dist/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ppc sparc x86"
+
+DEPEND="virtual/opengl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-X11.patch
+ eautoreconf
+ # Since plib only provides static libraries, force
+ # building as PIC or plib is useless to amd64/etc...
+ append-flags -fPIC
+}
+
+src_install() {
+ default
+ dodoc AUTHORS ChangeLog KNOWN_BUGS NOTICE README* TODO*
+}