summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-06-09 22:22:18 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-09 22:24:16 +0200
commit9065c85aa8c015d1e35d9d42e97ae311c986e52c (patch)
tree83e314020b41df2f895a6111f5c95d25d6e3cdef /media-libs/ptex/files
parentapp-portage/unsymlink-lib: amd64 stable wrt bug #687590 (diff)
downloadgentoo-9065c85aa8c015d1e35d9d42e97ae311c986e52c.tar.gz
gentoo-9065c85aa8c015d1e35d9d42e97ae311c986e52c.tar.bz2
gentoo-9065c85aa8c015d1e35d9d42e97ae311c986e52c.zip
media-libs/ptex: Drop 2.1.28-r1 and 2.3.0
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/ptex/files')
-rw-r--r--media-libs/ptex/files/ptex-2.1.28-20170213.patch72
-rw-r--r--media-libs/ptex/files/ptex-2.1.28-allow-custom-build-type.patch39
-rw-r--r--media-libs/ptex/files/ptex-2.3.0-cxx11.patch12
3 files changed, 0 insertions, 123 deletions
diff --git a/media-libs/ptex/files/ptex-2.1.28-20170213.patch b/media-libs/ptex/files/ptex-2.1.28-20170213.patch
deleted file mode 100644
index 335d07788632..000000000000
--- a/media-libs/ptex/files/ptex-2.1.28-20170213.patch
+++ /dev/null
@@ -1,72 +0,0 @@
-diff -purN a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt 2016-04-04 18:14:05.000000000 +0100
-+++ b/CMakeLists.txt 2017-02-13 22:59:10.000000000 +0000
-@@ -16,7 +16,7 @@ else ()
- endif ()
-
- if (NOT WIN32)
-- set(CMAKE_CXX_FLAGS "-std=c++98 -Wall -Wextra -pedantic")
-+ set(CMAKE_CXX_FLAGS "-std=c++11 -Wall -Wextra -pedantic ${CMAKE_CXX_FLAGS}")
- endif ()
-
- if(MSVC)
-diff -purN a/Makefile b/Makefile
---- a/Makefile 2016-04-04 18:14:05.000000000 +0100
-+++ b/Makefile 2017-02-13 22:59:10.000000000 +0000
-@@ -17,6 +17,10 @@ ifdef PRMAN_15_COMPATIBLE_PTEX
- CMAKE_FLAGS += -DPRMAN_15_COMPATIBLE_PTEX:BOOL=TRUE
- endif
-
-+ifdef TOOLCHAIN
-+ CMAKE_FLAGS += -DCMAKE_TOOLCHAIN_FILE=$(TOOLCHAIN)
-+endif
-+
- # make V=1 shortcut for VERBOSE=1
- ifdef V
- VERBOSE=1
-diff -purN a/src/ptex/PtexHashMap.h b/src/ptex/PtexHashMap.h
---- a/src/ptex/PtexHashMap.h 2016-04-04 18:14:05.000000000 +0100
-+++ b/src/ptex/PtexHashMap.h 2017-02-13 22:59:10.000000000 +0000
-@@ -284,14 +284,11 @@ private:
-
- Entry* lockEntriesAndGrowIfNeeded(size_t& newMemUsed)
- {
-- while (_size*2 >= _numEntries) {
-- Entry* entries = lockEntries();
-- if (_size*2 >= _numEntries) {
-- entries = grow(entries, newMemUsed);
-- }
-- return entries;
-+ Entry* entries = lockEntries();
-+ if (_size*2 >= _numEntries) {
-+ entries = grow(entries, newMemUsed);
- }
-- return lockEntries();
-+ return entries;
- }
-
- Entry* grow(Entry* oldEntries, size_t& newMemUsed)
-diff -purN a/src/ptex/PtexIO.h b/src/ptex/PtexIO.h
---- a/src/ptex/PtexIO.h 2016-04-04 18:14:05.000000000 +0100
-+++ b/src/ptex/PtexIO.h 2017-02-13 22:59:10.000000000 +0000
-@@ -40,6 +40,7 @@ OF THIS SOFTWARE, EVEN IF ADVISED OF THE
-
- PTEX_NAMESPACE_BEGIN
-
-+#pragma pack(push, 1)
- struct Header {
- uint32_t magic;
- uint32_t version;
-@@ -98,6 +99,7 @@ struct EditMetaDataHeader {
- uint32_t metadatazipsize;
- uint32_t metadatamemsize;
- };
-+#pragma pack(pop)
-
- const uint32_t Magic = 'P' | ('t'<<8) | ('e'<<16) | ('x'<<24);
- const int HeaderSize = sizeof(Header);
-diff -purN a/.workonrc.products b/.workonrc.products
---- a/.workonrc.products 1970-01-01 01:00:00.000000000 +0100
-+++ b/.workonrc.products 2017-02-13 22:59:10.000000000 +0000
-@@ -0,0 +1 @@
-+Ptex
diff --git a/media-libs/ptex/files/ptex-2.1.28-allow-custom-build-type.patch b/media-libs/ptex/files/ptex-2.1.28-allow-custom-build-type.patch
deleted file mode 100644
index fd79759f7ed4..000000000000
--- a/media-libs/ptex/files/ptex-2.1.28-allow-custom-build-type.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-diff -purN a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt 2017-02-13 22:59:10.000000000 +0000
-+++ b/CMakeLists.txt 2017-08-08 14:19:10.325817085 +0100
-@@ -8,11 +8,16 @@ include(FindThreads)
-
- enable_testing()
-
--# Detect the build type from the $FLAVOR environment variable
--if ("$ENV{FLAVOR}" MATCHES "debug")
-- set(CMAKE_BUILD_TYPE "Debug" CACHE STRING "type of build" FORCE)
--else ()
-- set(CMAKE_BUILD_TYPE "Release" CACHE STRING "type of build" FORCE)
-+if (NOT CMAKE_BUILD_TYPE AND NOT CMAKE_CONFIGURATION_TYPES)
-+ # Detect the build type from the $FLAVOR environment variable
-+ # Default to optimized Release builds when unspecified.
-+ if ("$ENV{FLAVOR}" MATCHES "debug")
-+ set(CMAKE_BUILD_TYPE "Debug" CACHE STRING "type of build" FORCE)
-+ elseif ("$ENV{FLAVOR}" MATCHES "profile")
-+ set(CMAKE_BUILD_TYPE "RelWithDebInfo" CACHE STRING "type of build" FORCE)
-+ else ()
-+ set(CMAKE_BUILD_TYPE "Release" CACHE STRING "type of build" FORCE)
-+ endif ()
- endif ()
-
- if (NOT WIN32)
-diff -purN a/Makefile b/Makefile
---- a/Makefile 2017-02-13 22:59:10.000000000 +0000
-+++ b/Makefile 2017-08-08 14:19:16.939829578 +0100
-@@ -21,6 +21,10 @@ ifdef TOOLCHAIN
- CMAKE_FLAGS += -DCMAKE_TOOLCHAIN_FILE=$(TOOLCHAIN)
- endif
-
-+ifdef BUILD_TYPE
-+ CMAKE_FLAGS += -DCMAKE_BUILD_TYPE=$(BUILD_TYPE)
-+endif
-+
- # make V=1 shortcut for VERBOSE=1
- ifdef V
- VERBOSE=1
diff --git a/media-libs/ptex/files/ptex-2.3.0-cxx11.patch b/media-libs/ptex/files/ptex-2.3.0-cxx11.patch
deleted file mode 100644
index f0b600091377..000000000000
--- a/media-libs/ptex/files/ptex-2.3.0-cxx11.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -purN a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt 2016-04-04 18:14:05.000000000 +0100
-+++ b/CMakeLists.txt 2017-02-13 22:59:10.000000000 +0000
-@@ -16,7 +16,7 @@ else ()
- endif ()
-
- if (NOT WIN32)
-- set(CMAKE_CXX_FLAGS "-std=c++98 -Wall -Wextra -pedantic ${CMAKE_CXX_FLAGS}")
-+ set(CMAKE_CXX_FLAGS "-std=c++11 -Wall -Wextra -pedantic ${CMAKE_CXX_FLAGS}")
- endif ()
-
- if(MSVC)