summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Scruggs <j.scruggs@gmail.com>2017-09-21 10:26:32 +0100
committerDavid Seifert <soap@gentoo.org>2017-09-23 10:37:18 +0200
commit952cb1555b5ec3b133b5f0deb4fdd26810d5ae47 (patch)
tree928ba66f11f58f6b9bbeec681600f2bd96e7c74f /media-libs/ptex/ptex-2.1.28-r1.ebuild
parentmedia-libs/partio: New package (diff)
downloadgentoo-952cb1555b5ec3b133b5f0deb4fdd26810d5ae47.tar.gz
gentoo-952cb1555b5ec3b133b5f0deb4fdd26810d5ae47.tar.bz2
gentoo-952cb1555b5ec3b133b5f0deb4fdd26810d5ae47.zip
media-libs/ptex: revision bump to 2.1.28-r1
* Add latest upstream fixes * Add patch to allow custom build types Closes: https://github.com/gentoo/gentoo/pull/5753
Diffstat (limited to 'media-libs/ptex/ptex-2.1.28-r1.ebuild')
-rw-r--r--media-libs/ptex/ptex-2.1.28-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/media-libs/ptex/ptex-2.1.28-r1.ebuild b/media-libs/ptex/ptex-2.1.28-r1.ebuild
new file mode 100644
index 000000000000..494ddef43b0e
--- /dev/null
+++ b/media-libs/ptex/ptex-2.1.28-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Per-Face Texture Mapping for Production Rendering"
+HOMEPAGE="http://ptex.us/"
+SRC_URI="https://github.com/wdas/ptex/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-libs/zlib:="
+DEPEND="${RDEPEND}
+ app-doc/doxygen"
+
+PATCHES=(
+ "${FILESDIR}/${P}-20170213.patch"
+ "${FILESDIR}/${P}-allow-custom-build-type.patch"
+)
+
+mycmakeargs=( -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}/html" )