summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Scruggs <j.scruggs@gmail.com>2018-08-15 18:35:27 +0100
committerJonathan Scruggs <dracwyrm@gentoo.org>2018-08-15 21:08:17 +0100
commitcf90a26960bf46cafe077d8eee562044ac4d8dd1 (patch)
treebcea925e1304bcfe3ee02676303212842fcc6a3d /media-libs/ptex/ptex-2.3.0.ebuild
parentmedia-libs/partio: bump to version 1.5.4 (diff)
downloadgentoo-cf90a26960bf46cafe077d8eee562044ac4d8dd1.tar.gz
gentoo-cf90a26960bf46cafe077d8eee562044ac4d8dd1.tar.bz2
gentoo-cf90a26960bf46cafe077d8eee562044ac4d8dd1.zip
media-libs/ptex: bump to version 2.3.0
Restrict tests as not fixed upstream: Closes: https://bugs.gentoo.org/646006
Diffstat (limited to 'media-libs/ptex/ptex-2.3.0.ebuild')
-rw-r--r--media-libs/ptex/ptex-2.3.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-libs/ptex/ptex-2.3.0.ebuild b/media-libs/ptex/ptex-2.3.0.ebuild
new file mode 100644
index 000000000000..b3cec3d387bf
--- /dev/null
+++ b/media-libs/ptex/ptex-2.3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Per-Face Texture Mapping for Production Rendering"
+HOMEPAGE="http://ptex.us/"
+SRC_URI="https://github.com/wdas/ptex/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="sys-libs/zlib:="
+DEPEND="${RDEPEND}
+ app-doc/doxygen"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${P}-cxx11.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}/html"
+ -DPTEX_BUILD_STATIC_LIBS=$(usex static-libs)
+ )
+ cmake-utils_src_configure
+}