summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-02 21:42:58 +0000
committerSam James <sam@gentoo.org>2021-01-02 21:43:02 +0000
commit34be49dbc8576c401dc7fcabf16f1a5584063d82 (patch)
tree285dd2bc6feb9e74db629dd419d7ed8c32eb5215 /media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20201201.ebuild
parentnet-misc/iperf: Remove ipv6 patch from live ebuild (diff)
downloadgentoo-34be49dbc8576c401dc7fcabf16f1a5584063d82.tar.gz
gentoo-34be49dbc8576c401dc7fcabf16f1a5584063d82.tar.bz2
gentoo-34be49dbc8576c401dc7fcabf16f1a5584063d82.zip
media-libs/raspberrypi-userland-bin: bump to 1.20201201
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20201201.ebuild')
-rw-r--r--media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20201201.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20201201.ebuild b/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20201201.ebuild
new file mode 100644
index 000000000000..9ce4a8fd7918
--- /dev/null
+++ b/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20201201.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="raspberrypi-firmware-${PV}"
+DESCRIPTION="Raspberry Pi userspace tools and libraries"
+HOMEPAGE="https://github.com/raspberrypi/firmware"
+SRC_URI="https://github.com/raspberrypi/firmware/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/firmware-${PV}"
+
+LICENSE="BSD GPL-2 raspberrypi-videocore-bin"
+SLOT="0"
+KEYWORDS="-* ~arm"
+IUSE="+hardfp examples"
+
+RDEPEND="!media-libs/raspberrypi-userland"
+DEPEND="${DEPEND}"
+RESTRICT="binchecks strip"
+
+src_install() {
+ cd $(usex hardfp hardfp/ "")opt/vc || die
+
+ insinto /opt/vc
+ doins -r include
+
+ into /opt
+ dobin bin/*
+
+ insopts -m 0755
+ insinto "/opt/vc/lib"
+ doins -r lib/*
+
+ doenvd "${FILESDIR}"/04${PN}
+
+ if use examples ; then
+ insopts -m 0644
+ docinto examples
+ dodoc -r src/hello_pi
+ fi
+}