summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2017-02-12 15:33:47 +0100
committerTupone Alfredo <tupone@gentoo.org>2017-02-12 15:33:47 +0100
commita18a8c4cbfc39c02825851d24e9e9ab777c4706b (patch)
treed3cf6f9c2946d1791cf7622ca673a2a1c1a2185a /media-libs/raspberrypi-userland/raspberrypi-userland-9999.ebuild
parentmedia-sound/mt-daapd: fix bug 335298 (diff)
downloadgentoo-a18a8c4cbfc39c02825851d24e9e9ab777c4706b.tar.gz
gentoo-a18a8c4cbfc39c02825851d24e9e9ab777c4706b.tar.bz2
gentoo-a18a8c4cbfc39c02825851d24e9e9ab777c4706b.zip
media-libs/raspberrypi-userland: Fix devices permissions
Not using anymore eselect opengl (includes not compatible) Package-Manager: portage-2.3.3
Diffstat (limited to 'media-libs/raspberrypi-userland/raspberrypi-userland-9999.ebuild')
-rw-r--r--media-libs/raspberrypi-userland/raspberrypi-userland-9999.ebuild26
1 files changed, 10 insertions, 16 deletions
diff --git a/media-libs/raspberrypi-userland/raspberrypi-userland-9999.ebuild b/media-libs/raspberrypi-userland/raspberrypi-userland-9999.ebuild
index c7448085bbb3..cc5ecd0b8271 100644
--- a/media-libs/raspberrypi-userland/raspberrypi-userland-9999.ebuild
+++ b/media-libs/raspberrypi-userland/raspberrypi-userland-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit cmake-utils git-r3
+inherit cmake-utils flag-o-matic git-r3
DESCRIPTION="Raspberry Pi userspace tools and libraries"
HOMEPAGE="https://github.com/raspberrypi/userland"
@@ -19,6 +19,12 @@ RDEPEND=""
EGIT_REPO_URI="https://github.com/raspberrypi/userland"
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+pkg_setup() {
+ append-ldflags $(no-as-needed)
+}
+
src_configure() {
local mycmakeargs=(
-DVMCS_INSTALL_PREFIX="/usr"
@@ -30,20 +36,8 @@ src_configure() {
src_install() {
cmake-utils_src_install
- dodir /usr/lib/opengl/raspberrypi/lib
- touch "${D}"/usr/lib/opengl/raspberrypi/.gles-only
- mv "${D}"/usr/lib/lib{EGL,GLESv2}* \
- "${D}"/usr/lib/opengl/raspberrypi/lib
-
- dodir /usr/lib/opengl/raspberrypi/include
- mv "${D}"/usr/include/{EGL,GLES,GLES2,KHR,WF} \
- "${D}"/usr/lib/opengl/raspberrypi/include
- mv "${D}"/usr/include/interface/vcos/pthreads/* \
- "${D}"/usr/include/interface/vcos/
- rmdir "${D}"/usr/include/interface/vcos/pthreads
- mv "${D}"/usr/include/interface/vmcs_host/linux/* \
- "${D}"/usr/include/interface/vmcs_host/
- rmdir "${D}"/usr/include/interface/vmcs_host/linux
+ insinto /lib/udev/rules.d
+ doins "${FILESDIR}"/92-local-vchiq-permissions.rules
dodir /usr/share/doc/${PF}
mv "${D}"/usr/src/hello_pi "${D}"/usr/share/doc/${PF}/