summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-02-24 11:09:02 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-02-24 11:34:58 +0100
commitd98a497a41fa9c41389ced6466461d379ff9d5d1 (patch)
treeb3f4577fffb2eeb455afe559bf4741f12b4a6fac /media-libs/sdl-gfx/sdl-gfx-2.0.26.ebuild
parentgames-rpg/manaplus: Removed old. (diff)
downloadgentoo-d98a497a41fa9c41389ced6466461d379ff9d5d1.tar.gz
gentoo-d98a497a41fa9c41389ced6466461d379ff9d5d1.tar.bz2
gentoo-d98a497a41fa9c41389ced6466461d379ff9d5d1.zip
media-libs/sdl-gfx: Bump to version 2.0.26
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'media-libs/sdl-gfx/sdl-gfx-2.0.26.ebuild')
-rw-r--r--media-libs/sdl-gfx/sdl-gfx-2.0.26.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/media-libs/sdl-gfx/sdl-gfx-2.0.26.ebuild b/media-libs/sdl-gfx/sdl-gfx-2.0.26.ebuild
new file mode 100644
index 000000000000..d0554bd00609
--- /dev/null
+++ b/media-libs/sdl-gfx/sdl-gfx-2.0.26.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools multilib-minimal
+
+MY_P="${P/sdl-/SDL_}"
+DESCRIPTION="Graphics drawing primitives library for SDL"
+HOMEPAGE="http://www.ferzkopp.net/joomla/content/view/19/14/"
+SRC_URI="http://www.ferzkopp.net/Software/SDL_gfx-2.0/${MY_P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc cpu_flags_x86_mmx static-libs"
+
+RDEPEND=">=media-libs/libsdl-1.2.15-r4[video,${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS ChangeLog README )
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ sed -i -e 's/-O //' configure.in || die
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-dependency-tracking \
+ $(use_enable cpu_flags_x86_mmx mmx) \
+ $(use_enable static-libs static)
+}
+
+#multilib_src_install() {
+# emake DESTDIR="${D}" install
+#}
+
+multilib_src_install_all() {
+ einstalldocs
+ if use doc ; then
+ docinto html
+ dodoc -r Docs/*
+ fi
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+}