summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-18 06:32:32 +0000
committerSam James <sam@gentoo.org>2024-03-18 07:20:19 +0000
commitafaa9e3fb5c34b1d7b67edc87b24491614e4ea4b (patch)
tree9457f3fa687805e6dada19c63e0cb55b735f5478 /media-libs/sdl2-image
parentmedia-libs/sdl2-ttf: add 2.22.0 (diff)
downloadgentoo-afaa9e3fb5c34b1d7b67edc87b24491614e4ea4b.tar.gz
gentoo-afaa9e3fb5c34b1d7b67edc87b24491614e4ea4b.tar.bz2
gentoo-afaa9e3fb5c34b1d7b67edc87b24491614e4ea4b.zip
media-libs/sdl2-image: add 2.8.2
With tests wired up now too. Bug: https://bugs.gentoo.org/927188 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/sdl2-image')
-rw-r--r--media-libs/sdl2-image/Manifest1
-rw-r--r--media-libs/sdl2-image/sdl2-image-2.8.2.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/media-libs/sdl2-image/Manifest b/media-libs/sdl2-image/Manifest
index 4f3258d95c5d..e580db1e41da 100644
--- a/media-libs/sdl2-image/Manifest
+++ b/media-libs/sdl2-image/Manifest
@@ -1,2 +1,3 @@
DIST SDL2_image-2.0.5_p20210328.tar.gz 12397062 BLAKE2B ae4fe8c30b21bc7dca87e2e78cab43c83e891630962eb020c29ba84c2b206bb749491dccddd8bcc212f2fd07da651691151baf41212fb5ea954427543e3bf994 SHA512 9ba0b671dedfb7bde072424cebfa7d65e79d2d58416833d84548777aff6bf0edda8dbe30c3e423bbb724f794b4b191e609b148f38573b4166eef31203ab0005d
DIST SDL2_image-2.6.3.tar.gz 9816720 BLAKE2B 24662637e4f621af83d9a66d1cca954549030be97fa47f4b8fc711b2a941eaa409cf99ede137eb91d25999af253791dcfb2d9229080d30ede84cc32d5c5ae997 SHA512 11f1d041a052829708560b6211a2a00b3a1ce26a6f23cb389f57fa5254372027e97d3a6ffe551134a77bc33718c3acea3df21fe8426e93a2b1955176c47c7647
+DIST SDL2_image-2.8.2.tar.gz 11362515 BLAKE2B 8bc8967eed7203ddbd23062e257ae8768eeb28e8efa57bac86db0224a7cdc94dfbb10c6da77dab9c1847f216ec761fae5b7bd5d8ed25c6b3c69ad972dc93ddf5 SHA512 0ff345824f95158dfa72f83f9d4a540601c178cd759334bf849c14a2920b5330d0763413b58c08b3deba8d3a4ccb6ea2a8159f87efe4cbb0e8ea850f63d09454
diff --git a/media-libs/sdl2-image/sdl2-image-2.8.2.ebuild b/media-libs/sdl2-image/sdl2-image-2.8.2.ebuild
new file mode 100644
index 000000000000..630c584acce1
--- /dev/null
+++ b/media-libs/sdl2-image/sdl2-image-2.8.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib multilib-minimal toolchain-funcs
+
+MY_P="SDL2_image-${PV}"
+DESCRIPTION="Image file loading library"
+HOMEPAGE="https://www.libsdl.org/projects/SDL_image/"
+SRC_URI="https://github.com/libsdl-org/SDL_image/releases/download/release-${PV}/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc64 ~riscv ~sparc ~x86"
+IUSE="avif gif jpeg jpegxl png static-libs test tiff webp"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=media-libs/libsdl2-2.0.9[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ avif? ( >=media-libs/libavif-0.9.3:=[${MULTILIB_USEDEP}] )
+ png? ( >=media-libs/libpng-1.6.10:0[${MULTILIB_USEDEP}] )
+ jpeg? ( media-libs/libjpeg-turbo:=[${MULTILIB_USEDEP}] )
+ jpegxl? ( media-libs/libjxl:=[${MULTILIB_USEDEP}] )
+ tiff? ( >=media-libs/tiff-3.9.7-r1:=[${MULTILIB_USEDEP}] )
+ webp? ( >=media-libs/libwebp-0.3.0:=[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ $(use_enable avif)
+ --disable-avif-shared
+ --disable-sdltest
+ --disable-stb-image
+ --enable-bmp
+ $(use_enable gif)
+ $(use_enable jpeg jpg)
+ --disable-jpg-shared
+ $(use_enable jpegxl jxl)
+ --disable-jxl-shared
+ --enable-lbm
+ --enable-pcx
+ $(use_enable png)
+ --disable-png-shared
+ --enable-pnm
+ $(use_enable test tests)
+ --enable-tga
+ $(use_enable tiff tif)
+ --disable-tif-shared
+ --enable-qoi
+ --enable-xcf
+ --enable-xpm
+ --enable-xv
+ $(use_enable webp)
+ --disable-webp-shared
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_compile() {
+ emake OBJC="$(tc-getCC)"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ multilib_is_native_abi && newbin .libs/showimage$(get_exeext) showimage2$(get_exeext)
+}
+
+multilib_src_install_all() {
+ dodoc {CHANGES,README}.txt
+ find "${ED}" -type f -name "*.la" -delete || die
+}