summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-22 14:28:46 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-22 19:31:48 +0200
commitbe6eb7a6655beab993413e99bd0deea55199409f (patch)
treec95b35bcc73b0ed1d7e6cef0c9526762c3263fbe /media-libs/sdl2-image
parentmedia-libs/sdl2-image: Enable qoi image format (diff)
downloadgentoo-be6eb7a6655beab993413e99bd0deea55199409f.tar.gz
gentoo-be6eb7a6655beab993413e99bd0deea55199409f.tar.bz2
gentoo-be6eb7a6655beab993413e99bd0deea55199409f.zip
media-libs/sdl2-image: Add a flag for JPEGXL support
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-libs/sdl2-image')
-rw-r--r--media-libs/sdl2-image/metadata.xml1
-rw-r--r--media-libs/sdl2-image/sdl2-image-2.6.3-r1.ebuild5
2 files changed, 4 insertions, 2 deletions
diff --git a/media-libs/sdl2-image/metadata.xml b/media-libs/sdl2-image/metadata.xml
index 0cb609f528f0..640e22b53423 100644
--- a/media-libs/sdl2-image/metadata.xml
+++ b/media-libs/sdl2-image/metadata.xml
@@ -10,6 +10,7 @@
<bugs-to>https://github.com/libsdl-org/SDL_image/issues</bugs-to>
</upstream>
<use>
+ <flag name="jpegxl">Enable support for JPEG XL image format</flag>
<flag name="webp">support loading WEBP images</flag>
</use>
</pkgmetadata>
diff --git a/media-libs/sdl2-image/sdl2-image-2.6.3-r1.ebuild b/media-libs/sdl2-image/sdl2-image-2.6.3-r1.ebuild
index d9cfbcb958f5..ee83fbbedb1a 100644
--- a/media-libs/sdl2-image/sdl2-image-2.6.3-r1.ebuild
+++ b/media-libs/sdl2-image/sdl2-image-2.6.3-r1.ebuild
@@ -14,13 +14,14 @@ S="${WORKDIR}"/${MY_P}
LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
-IUSE="gif jpeg png static-libs tiff webp"
+IUSE="gif jpeg jpegxl png static-libs tiff webp"
RDEPEND="
>=media-libs/libsdl2-2.0.9[${MULTILIB_USEDEP}]
>=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
png? ( >=media-libs/libpng-1.6.10:0[${MULTILIB_USEDEP}] )
jpeg? ( media-libs/libjpeg-turbo:=[${MULTILIB_USEDEP}] )
+ jpegxl? ( media-libs/libjxl:=[${MULTILIB_USEDEP}] )
tiff? ( >=media-libs/tiff-3.9.7-r1:=[${MULTILIB_USEDEP}] )
webp? ( >=media-libs/libwebp-0.3.0:=[${MULTILIB_USEDEP}] )
"
@@ -37,7 +38,7 @@ multilib_src_configure() {
$(use_enable gif)
$(use_enable jpeg jpg)
--disable-jpg-shared
- --disable-jxl
+ $(use_enable jpegxl jxl)
--disable-jxl-shared
--enable-lbm
--enable-pcx