summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-12 05:43:35 +0000
committerSam James <sam@gentoo.org>2023-02-12 05:59:04 +0000
commitc115635223d3abee37178b30d28ee76cd993e501 (patch)
tree6be53291616c5f042416b2ace3acdba8de85bc9a /media-libs/sdl2-image
parentmedia-libs/freetype: add 2.13.0 (diff)
downloadgentoo-c115635223d3abee37178b30d28ee76cd993e501.tar.gz
gentoo-c115635223d3abee37178b30d28ee76cd993e501.tar.bz2
gentoo-c115635223d3abee37178b30d28ee76cd993e501.zip
media-libs/sdl2-image: add 2.6.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/sdl2-image')
-rw-r--r--media-libs/sdl2-image/Manifest1
-rw-r--r--media-libs/sdl2-image/sdl2-image-2.6.3.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/media-libs/sdl2-image/Manifest b/media-libs/sdl2-image/Manifest
index a1ee4a65116a..4f3258d95c5d 100644
--- a/media-libs/sdl2-image/Manifest
+++ b/media-libs/sdl2-image/Manifest
@@ -1 +1,2 @@
DIST SDL2_image-2.0.5_p20210328.tar.gz 12397062 BLAKE2B ae4fe8c30b21bc7dca87e2e78cab43c83e891630962eb020c29ba84c2b206bb749491dccddd8bcc212f2fd07da651691151baf41212fb5ea954427543e3bf994 SHA512 9ba0b671dedfb7bde072424cebfa7d65e79d2d58416833d84548777aff6bf0edda8dbe30c3e423bbb724f794b4b191e609b148f38573b4166eef31203ab0005d
+DIST SDL2_image-2.6.3.tar.gz 9816720 BLAKE2B 24662637e4f621af83d9a66d1cca954549030be97fa47f4b8fc711b2a941eaa409cf99ede137eb91d25999af253791dcfb2d9229080d30ede84cc32d5c5ae997 SHA512 11f1d041a052829708560b6211a2a00b3a1ce26a6f23cb389f57fa5254372027e97d3a6ffe551134a77bc33718c3acea3df21fe8426e93a2b1955176c47c7647
diff --git a/media-libs/sdl2-image/sdl2-image-2.6.3.ebuild b/media-libs/sdl2-image/sdl2-image-2.6.3.ebuild
new file mode 100644
index 000000000000..589bcfbc82ea
--- /dev/null
+++ b/media-libs/sdl2-image/sdl2-image-2.6.3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib multilib-minimal toolchain-funcs
+
+MY_P="SDL2_image-${PV}"
+DESCRIPTION="Image file loading library"
+HOMEPAGE="https://www.libsdl.org/projects/SDL_image/"
+SRC_URI="https://github.com/libsdl-org/SDL_image/releases/download/release-2.6.3/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="gif jpeg png static-libs tiff webp"
+
+RDEPEND="
+ >=media-libs/libsdl2-2.0.9[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ png? ( >=media-libs/libpng-1.6.10:0[${MULTILIB_USEDEP}] )
+ jpeg? ( media-libs/libjpeg-turbo:=[${MULTILIB_USEDEP}] )
+ tiff? ( >=media-libs/tiff-3.9.7-r1:=[${MULTILIB_USEDEP}] )
+ webp? ( >=media-libs/libwebp-0.3.0:=[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ --disable-avif
+ --disable-avif-shared
+ --disable-sdltest
+ --disable-stb-image
+ --enable-bmp
+ $(use_enable gif)
+ $(use_enable jpeg jpg)
+ --disable-jpg-shared
+ --disable-jxl
+ --disable-jxl-shared
+ --enable-lbm
+ --enable-pcx
+ $(use_enable png)
+ --disable-png-shared
+ --enable-pnm
+ --enable-tga
+ $(use_enable tiff tif)
+ --disable-tif-shared
+ --disable-qoi
+ --enable-xcf
+ --enable-xpm
+ --enable-xv
+ $(use_enable webp)
+ --disable-webp-shared
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_compile() {
+ emake OBJC="$(tc-getCC)"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ multilib_is_native_abi && newbin .libs/showimage$(get_exeext) showimage2$(get_exeext)
+}
+
+multilib_src_install_all() {
+ dodoc {CHANGES,README}.txt
+ find "${ED}" -type f -name "*.la" -delete || die
+}