summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-01-03 22:01:36 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2016-01-03 22:01:36 -0500
commit1d3c3d90338d22f8491e02b7b301a9c0d0183509 (patch)
treebe35b3c31c77905dd47980cec7ab6f88226aa688 /media-libs/sdl2-ttf/sdl2-ttf-2.0.13.ebuild
parentmedia-libs/sdl2-net: version bump (diff)
downloadgentoo-1d3c3d90338d22f8491e02b7b301a9c0d0183509.tar.gz
gentoo-1d3c3d90338d22f8491e02b7b301a9c0d0183509.tar.bz2
gentoo-1d3c3d90338d22f8491e02b7b301a9c0d0183509.zip
media-libs/sdl2-ttf: version bump
Package-Manager: portage-2.2.24
Diffstat (limited to 'media-libs/sdl2-ttf/sdl2-ttf-2.0.13.ebuild')
-rw-r--r--media-libs/sdl2-ttf/sdl2-ttf-2.0.13.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-libs/sdl2-ttf/sdl2-ttf-2.0.13.ebuild b/media-libs/sdl2-ttf/sdl2-ttf-2.0.13.ebuild
new file mode 100644
index 000000000000..fb718731b1c2
--- /dev/null
+++ b/media-libs/sdl2-ttf/sdl2-ttf-2.0.13.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils multilib-minimal
+
+MY_P=SDL2_ttf-${PV}
+DESCRIPTION="library that allows you to use TrueType fonts in SDL applications"
+HOMEPAGE="http://www.libsdl.org/projects/SDL_ttf/"
+SRC_URI="http://www.libsdl.org/projects/SDL_ttf/release/${MY_P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs X"
+
+RDEPEND="X? ( >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}] )
+ >=media-libs/libsdl2-2.0.1-r1[${MULTILIB_USEDEP}]
+ >=media-libs/freetype-2.5.0.1[${MULTILIB_USEDEP}]"
+DEPEND=${RDEPEND}
+
+S=${WORKDIR}/${MY_P}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static) \
+ $(use_with X x)
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ dodoc {CHANGES,README}.txt
+ prune_libtool_files
+}