summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/spandsp/spandsp-0.0.6_pre21.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/spandsp/spandsp-0.0.6_pre21.ebuild')
-rw-r--r--media-libs/spandsp/spandsp-0.0.6_pre21.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/media-libs/spandsp/spandsp-0.0.6_pre21.ebuild b/media-libs/spandsp/spandsp-0.0.6_pre21.ebuild
new file mode 100644
index 000000000000..ddeb57f684b8
--- /dev/null
+++ b/media-libs/spandsp/spandsp-0.0.6_pre21.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit multilib versionator
+
+DESCRIPTION="SpanDSP is a library of DSP functions for telephony"
+HOMEPAGE="http://www.soft-switch.org/"
+SRC_URI="http://www.soft-switch.org/downloads/spandsp/${P/_}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="doc fixed-point cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 static-libs"
+
+RDEPEND="media-libs/tiff"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen
+ dev-libs/libxslt )"
+
+S=${WORKDIR}/${PN}-$(get_version_component_range 1-3)
+
+# TODO:
+# there are two tests options: tests and test-data
+# they need audiofile, fftw, libxml and probably more
+# configure script is auto-enabling some sse* options sometimes
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable doc) \
+ $(use_enable fixed-point) \
+ $(use_enable cpu_flags_x86_mmx mmx) \
+ $(use_enable cpu_flags_x86_sse2 sse2) \
+ $(use_enable cpu_flags_x86_sse3 sse3) \
+ $(use_enable static-libs static)
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog DueDiligence NEWS README
+
+ if ! use static-libs; then
+ # remove useless la file when not installing static lib
+ rm "${D}"/usr/$(get_libdir)/lib${PN}.la || die "rm failed"
+ fi
+
+ if use doc; then
+ dohtml -r doc/{api/html/*,t38_manual}
+ fi
+}