summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2017-03-03 12:59:43 -0800
committerMichael Palimaka <kensington@gentoo.org>2017-03-04 10:11:38 +1100
commit2776a627b16b7a06060cd2d563a77f35680f9910 (patch)
tree2495d393b0dfd375a7202b179d96febaf3fa1853 /media-libs/speex
parentmedia-libs/speexdsp: New package (diff)
downloadgentoo-2776a627b16b7a06060cd2d563a77f35680f9910.tar.gz
gentoo-2776a627b16b7a06060cd2d563a77f35680f9910.tar.bz2
gentoo-2776a627b16b7a06060cd2d563a77f35680f9910.zip
media-libs/speex: version bump to 1.2.0
Move to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/596400
Diffstat (limited to 'media-libs/speex')
-rw-r--r--media-libs/speex/Manifest1
-rw-r--r--media-libs/speex/files/speex-1.2.0-configure.patch27
-rw-r--r--media-libs/speex/metadata.xml19
-rw-r--r--media-libs/speex/speex-1.2.0.ebuild59
4 files changed, 99 insertions, 7 deletions
diff --git a/media-libs/speex/Manifest b/media-libs/speex/Manifest
index d7e33b8ef618..e5c7256f86e4 100644
--- a/media-libs/speex/Manifest
+++ b/media-libs/speex/Manifest
@@ -1 +1,2 @@
+DIST speex-1.2.0.tar.gz 1047080 SHA256 eaae8af0ac742dc7d542c9439ac72f1f385ce838392dc849cae4536af9210094 SHA512 7fe10838c7d1bafcbe42295b82b79262420dba793b8a4388e2f73a3007850b5572face1b5308d9f4e8d7dfc9cb1c016cbad88cd65b2892667986107ed946836b WHIRLPOOL 25274b640424318e06bceeb33c748f1299ebb35297ebbfe4a80aa183beb1fe4d3d656597e48d781c77ae104f9911770ffcebe9ff20a0fa555fbf68a07d5841d1
DIST speex-1.2rc1.tar.gz 1061882 SHA256 342f30dc57bd4a6dad41398365baaa690429660b10d866b7d508e8f1179cb7a6 SHA512 bdf1ddb2d60496ab220b94c1bec7a43f267fc964fdbb5cc9f24b71b9b571f237f5ce98c1d74b02699d71a95281f4694ff464ebec25e3b135244e5b3099cb1813 WHIRLPOOL c984f04a9c78332509b76ef98ff0eb84b8b4b8755d02890c5de41501325c2055e42243eaed2671e0087c8ca2cdea5967e5113c3d85a53f3704a8d8a3cfc487cb
diff --git a/media-libs/speex/files/speex-1.2.0-configure.patch b/media-libs/speex/files/speex-1.2.0-configure.patch
new file mode 100644
index 000000000000..e0aca82b908b
--- /dev/null
+++ b/media-libs/speex/files/speex-1.2.0-configure.patch
@@ -0,0 +1,27 @@
+diff -Naur speex-1.2.0.orig/configure.ac speex-1.2.0/configure.ac
+--- speex-1.2.0.orig/configure.ac 2016-12-12 13:53:12.254983043 -0800
++++ speex-1.2.0/configure.ac 2016-12-12 13:58:44.950298126 -0800
+@@ -138,7 +138,7 @@
+ AC_ARG_ENABLE(sse, [ --enable-sse Enable SSE support], [
+ if test "x$enableval" != xno; then
+ has_sse=yes
+-CFLAGS="$CFLAGS -O3 -msse"
++CFLAGS="$CFLAGS -msse"
+ else
+ has_sse=no
+ fi
+@@ -257,7 +257,13 @@
+
+ AM_CONDITIONAL(BUILD_VORBIS_PSY, [test "x$vorbis_psy" = "xyes"])
+
+-PKG_CHECK_MODULES([SPEEXDSP], [speexdsp], [AC_DEFINE([USE_SPEEXDSP], [], [Use SpeexDSP library])], [speexdsp_failed=yes])
++AC_ARG_WITH(speexdsp, [ --without-speexdsp Do not build with SpeexDSP])
++if test "x$withval" != xno; then
++ PKG_CHECK_MODULES([SPEEXDSP], [speexdsp], [AC_DEFINE([USE_SPEEXDSP], [], [Use SpeexDSP library])])
++else
++ AC_DEFINE([USE_SPEEXDSP], false)
++fi
++
+
+
+ AC_CHECK_SIZEOF([int16_t])
diff --git a/media-libs/speex/metadata.xml b/media-libs/speex/metadata.xml
index 18e9eb1cce00..7617efb01619 100644
--- a/media-libs/speex/metadata.xml
+++ b/media-libs/speex/metadata.xml
@@ -1,11 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>sound@gentoo.org</email>
- <name>Gentoo Sound project</name>
-</maintainer>
-<upstream>
- <remote-id type="cpe">cpe:/a:xiph:speex</remote-id>
-</upstream>
+ <maintainer type="project">
+ <email>sound@gentoo.org</email>
+ <name>Gentoo Sound project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpe">cpe:/a:xiph:speex</remote-id>
+ </upstream>
+ <use>
+ <flag name="armv5te">Enables optimizations for armv5te processors.</flag>
+ <flag name="utils">Enables speex commandline utilities (speexenc, speexdec).</flag>
+ <flag name="vbr">Enable VBR support.</flag>
+ </use>
</pkgmetadata>
diff --git a/media-libs/speex/speex-1.2.0.ebuild b/media-libs/speex/speex-1.2.0.ebuild
new file mode 100644
index 000000000000..33b2bb8cee1f
--- /dev/null
+++ b/media-libs/speex/speex-1.2.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools flag-o-matic multilib-minimal
+
+MY_P=${P/_}
+MY_P=${MY_P/_p/.}
+
+DESCRIPTION="Audio compression format designed for speech"
+HOMEPAGE="http://www.speex.org/"
+SRC_URI="http://downloads.xiph.org/releases/speex/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="armv5te cpu_flags_x86_sse static-libs utils +vbr"
+
+RDEPEND="
+ utils? (
+ media-libs/libogg:=
+ media-libs/speexdsp
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}/${P}-configure.patch" )
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's:noinst_PROGRAMS:check_PROGRAMS:' \
+ libspeex/Makefile.am || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ append-lfs-flags
+
+ # Can also be configured without floating point
+ # --enable-fixed-point
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static) \
+ $(usex arm $(usex armv5te '--disable-arm4-asm' '--enable-arm4-asm') '--disable-arm4-asm') \
+ $(use_enable armv5te arm5e-asm) \
+ $(use_enable cpu_flags_x86_sse sse) \
+ $(use_enable vbr) \
+ $(use_with utils speexdsp) \
+ $(use_enable utils binaries)
+}
+
+multilib_src_install_all() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}