summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2016-12-14 13:53:30 -0800
committerMichael Palimaka <kensington@gentoo.org>2017-03-04 10:11:34 +1100
commita0e0030ba45065e47f61c1381d283cf6162a733b (patch)
treeb5f68c8bc66c9d8cd00a42791135369a12d3cc0b /media-libs/speexdsp/speexdsp-1.2_rc3.ebuild
parentmail-filter/opendkim: support gnutls-3.4 + eapi bump (diff)
downloadgentoo-a0e0030ba45065e47f61c1381d283cf6162a733b.tar.gz
gentoo-a0e0030ba45065e47f61c1381d283cf6162a733b.tar.bz2
gentoo-a0e0030ba45065e47f61c1381d283cf6162a733b.zip
media-libs/speexdsp: New package
Diffstat (limited to 'media-libs/speexdsp/speexdsp-1.2_rc3.ebuild')
-rw-r--r--media-libs/speexdsp/speexdsp-1.2_rc3.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/media-libs/speexdsp/speexdsp-1.2_rc3.ebuild b/media-libs/speexdsp/speexdsp-1.2_rc3.ebuild
new file mode 100644
index 000000000000..b946550540a9
--- /dev/null
+++ b/media-libs/speexdsp/speexdsp-1.2_rc3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools flag-o-matic multilib-minimal
+
+MY_P=${P/_}
+MY_P=${MY_P/_p/.}
+
+DESCRIPTION="Audio compression format designed for speech -- DSP"
+HOMEPAGE="http://www.speex.org/"
+SRC_URI="http://downloads.xiph.org/releases/speex/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="cpu_flags_x86_sse cpu_flags_x86_sse2 neon static-libs"
+
+RDEPEND="!<media-libs/speex-1.2.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}/${P}-configure.patch" )
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's:noinst_PROGRAMS:check_PROGRAMS:' \
+ libspeexdsp/Makefile.am || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ append-lfs-flags
+
+ # Can also be configured with one of:
+ # --enable-fixed-point (no floating point)
+ # --with-fft=proprietary-intel-mkl (mkl)
+ # --with-fft=gpl-fftw3 (fftw)
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static) \
+ $(use_enable cpu_flags_x86_sse sse) \
+ $(use_enable cpu_flags_x86_sse2 sse2) \
+ $(use_enable neon)
+}
+
+multilib_src_install_all() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}