summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2019-12-19 18:34:23 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2019-12-19 18:34:47 +0100
commit63b556e6e77a4b2e0c2a575583fec374562b294d (patch)
treeaa032e397145e63a8261cb5716496e3052af2dae /media-libs/sratom/sratom-0.6.4.ebuild
parentdev-libs/sord: bump 0.16.4 (diff)
downloadgentoo-63b556e6e77a4b2e0c2a575583fec374562b294d.tar.gz
gentoo-63b556e6e77a4b2e0c2a575583fec374562b294d.tar.bz2
gentoo-63b556e6e77a4b2e0c2a575583fec374562b294d.zip
media-libs/sratom: bump 0.6.4
1) dropped python 2_7 and 3_5, added 3_{6,7,8} 2) updated deps Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-libs/sratom/sratom-0.6.4.ebuild')
-rw-r--r--media-libs/sratom/sratom-0.6.4.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/media-libs/sratom/sratom-0.6.4.ebuild b/media-libs/sratom/sratom-0.6.4.ebuild
new file mode 100644
index 000000000000..53a13bb862ac
--- /dev/null
+++ b/media-libs/sratom/sratom-0.6.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE='threads(+)'
+inherit python-any-r1 waf-utils multilib-build multilib-minimal
+
+DESCRIPTION="Library for serialising LV2 atoms to/from RDF, particularly the Turtle syntax"
+HOMEPAGE="http://drobilla.net/software/sratom/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=media-libs/lv2-1.16.0
+ >=dev-libs/serd-0.30.0
+ >=dev-libs/sord-0.14.0"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+DOCS=( "NEWS" "README.md" )
+
+src_prepare() {
+ sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
+ default
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ waf-utils_src_configure \
+ --docdir=/usr/share/doc/${PF} \
+ $(multilib_native_usex doc --docs "") \
+ $(usex test --test "") \
+ $(usex static-libs --static "")
+}
+
+multilib_src_test() {
+ ./waf test || die
+}
+
+multilib_src_compile() {
+ waf-utils_src_compile
+ default
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+ default
+}