summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/suil
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/suil')
-rw-r--r--media-libs/suil/Manifest2
-rw-r--r--media-libs/suil/metadata.xml8
-rw-r--r--media-libs/suil/suil-0.8.0.ebuild39
-rw-r--r--media-libs/suil/suil-0.8.2.ebuild41
4 files changed, 90 insertions, 0 deletions
diff --git a/media-libs/suil/Manifest b/media-libs/suil/Manifest
new file mode 100644
index 000000000000..d7389949f73d
--- /dev/null
+++ b/media-libs/suil/Manifest
@@ -0,0 +1,2 @@
+DIST suil-0.8.0.tar.bz2 138127 SHA256 f6d08797d07dd1f7a91f9cd04ac8814575cc4d90ff323972dd03ac1dd55bba78 SHA512 20b87f375b4e066d64f3b950ae8b137a2aa44b13a706c32e60f03e1179a0dac83395e44f0f3bc3e67822eab65c67f3c394caad8bda49048f0f5aa65e39bfd6ec WHIRLPOOL 52baa1496afc57daeb3fa3602bb6a8c5b693f68e258af59c88bc3a5f65cf8849e3146d4bc99e24c8fb78e8d7bc5a0d061ec05f32a9f8351922f5ea799a6405c2
+DIST suil-0.8.2.tar.bz2 141929 SHA256 787608c1e5b1f5051137dbf77c671266088583515af152b77b45e9c3a36f6ae8 SHA512 63141aa61a6501b735f38f597763b7190158db7b5bc06afd8989bddd70372d78de937820fa6751192aefaf415c417387426c1c1bdb666cf231f74a2c4c9f7e91 WHIRLPOOL e4aad86de286c29954aa53402cf7bd5c7d6c91c710b53738679ae361eadfa62c69481cdc94e6a4116a838d49f73bae11a7e849c116d95b5a0f57d9a57fdd5470
diff --git a/media-libs/suil/metadata.xml b/media-libs/suil/metadata.xml
new file mode 100644
index 000000000000..640383e7be81
--- /dev/null
+++ b/media-libs/suil/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proaudio</herd>
+<longdescription lang="en">
+ Lilv is a library to make the use of LV2 plugins as simple as possible for applications. Lilv is the successor to SLV2, rewritten to be significantly faster and have minimal dependencies.
+</longdescription>
+</pkgmetadata>
diff --git a/media-libs/suil/suil-0.8.0.ebuild b/media-libs/suil/suil-0.8.0.ebuild
new file mode 100644
index 000000000000..ce3325c08f69
--- /dev/null
+++ b/media-libs/suil/suil-0.8.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit base waf-utils
+
+DESCRIPTION="Lightweight C library for loading and wrapping LV2 plugin UIs"
+HOMEPAGE="http://drobilla.net/software/suil/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc gtk qt4"
+
+RDEPEND="media-libs/lv2
+ gtk? ( x11-libs/gtk+:2 )
+ qt4? ( dev-qt/qtgui:4 )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+DOCS=( "AUTHORS" "NEWS" "README" )
+
+src_prepare() {
+ sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
+}
+
+src_configure() {
+ # otherwise automagic
+ use gtk || sed -i -e 's/gtk+-2.0/DiSaBlEd/' wscript
+ use qt4 || sed -i -e 's/QtGui/DiSaBlEd/' wscript
+ waf-utils_src_configure \
+ "--mandir=${EPREFIX}/usr/share/man" \
+ "--docdir=${EPREFIX}/usr/share/doc/${PF}" \
+ $(use doc && echo "--docs")
+}
diff --git a/media-libs/suil/suil-0.8.2.ebuild b/media-libs/suil/suil-0.8.2.ebuild
new file mode 100644
index 000000000000..0a237fda0331
--- /dev/null
+++ b/media-libs/suil/suil-0.8.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE='threads(+)'
+
+inherit python-any-r1 waf-utils
+
+DESCRIPTION="Lightweight C library for loading and wrapping LV2 plugin UIs"
+HOMEPAGE="http://drobilla.net/software/suil/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc gtk qt4"
+
+RDEPEND="media-libs/lv2
+ gtk? ( x11-libs/gtk+:2 )
+ qt4? ( dev-qt/qtgui:4 )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+DOCS=( "AUTHORS" "NEWS" "README" )
+
+src_prepare() {
+ sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
+}
+
+src_configure() {
+ waf-utils_src_configure \
+ "--mandir=${EPREFIX}/usr/share/man" \
+ "--docdir=${EPREFIX}/usr/share/doc/${PF}" \
+ $(use gtk || echo "--no-gtk") \
+ $(use qt4 || echo "--no-qt") \
+ $(use doc && echo "--docs")
+}