summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-10-02 10:49:57 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2020-10-02 10:49:57 +0200
commiteae7cdf29fcbee0eac6660e8f84e89afaf9dec9e (patch)
treec94e590e2fb652c12f6624a1781209cc8a0ec2f0 /media-libs/suil
parentmedia-libs/sratom: bump to 0.6.6 + py3.9 (diff)
downloadgentoo-eae7cdf29fcbee0eac6660e8f84e89afaf9dec9e.tar.gz
gentoo-eae7cdf29fcbee0eac6660e8f84e89afaf9dec9e.tar.bz2
gentoo-eae7cdf29fcbee0eac6660e8f84e89afaf9dec9e.zip
media-libs/suil: bump to 0.10.8 + py3.8 & py3.9
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-libs/suil')
-rw-r--r--media-libs/suil/Manifest1
-rw-r--r--media-libs/suil/suil-0.10.8.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/media-libs/suil/Manifest b/media-libs/suil/Manifest
index f872957b956e..774ef55a9661 100644
--- a/media-libs/suil/Manifest
+++ b/media-libs/suil/Manifest
@@ -1 +1,2 @@
DIST suil-0.10.6.tar.bz2 347615 BLAKE2B 667379c6290c4c1e03168911fa58b991e95bbc7c7477606e42ba39d33645f4580ea09051d294f24cdbb3b2df9ed1d415b73eda3ec1f593fed2e7f2d9ff2a85c3 SHA512 b23ffe0c0ae25467b2cd60117a2efa8c13132c8e5612619e4c9ad2cc228b835f1c7fd384db62b74d4a327e3708f189b6a91f972756fcafe501308adb732c3b36
+DIST suil-0.10.8.tar.bz2 357003 BLAKE2B d5445a8a539d3aaca94141fe0a7bfce976db9602fcaa563d0e5661ce7d281ac48679110e5545d3a3aa4d3c488c5ce7a00f2f06bd67e56da26943885a71480648 SHA512 1d68996756ac593b2b2da6d9554e3257944cacbc8d70d90ded0f6ad5b5877778a08c779a12c7b4527d492f9c480613e030ab6933532f758e16221daa9d5c2dd4
diff --git a/media-libs/suil/suil-0.10.8.ebuild b/media-libs/suil/suil-0.10.8.ebuild
new file mode 100644
index 000000000000..491e16bf745f
--- /dev/null
+++ b/media-libs/suil/suil-0.10.8.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_REQ_USE='threads(+)'
+
+inherit flag-o-matic python-any-r1 waf-utils
+
+DESCRIPTION="Lightweight C library for loading and wrapping LV2 plugin UIs"
+HOMEPAGE="http://drobilla.net/software/suil/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="doc gtk qt5"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+CDEPEND="
+ media-libs/lv2
+ gtk? ( x11-libs/gtk+:2 )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ )"
+RDEPEND="${CDEPEND}"
+DEPEND="
+ ${CDEPEND}
+ ${PYTHON_DEPS}
+"
+
+DOCS=( AUTHORS NEWS README.md )
+
+src_prepare() {
+ default
+ sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
+}
+
+src_configure() {
+ waf-utils_src_configure \
+ --mandir="${EPREFIX}/usr/share/man" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --no-qt4 \
+ $(usex gtk '' --no-gtk) \
+ $(usex qt5 '' --no-qt5) \
+ $(usex doc --docs '')
+}