summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/tse3
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/tse3')
-rw-r--r--media-libs/tse3/Manifest2
-rw-r--r--media-libs/tse3/files/tse3-0.2.7-gcc4.patch10
-rw-r--r--media-libs/tse3/files/tse3-0.2.7-size_t-64bit.patch25
-rw-r--r--media-libs/tse3/files/tse3-0.3.1+gcc-4.3.patch80
-rw-r--r--media-libs/tse3/files/tse3-0.3.1-parallelmake.patch11
-rw-r--r--media-libs/tse3/metadata.xml8
-rw-r--r--media-libs/tse3/tse3-0.3.1-r1.ebuild51
7 files changed, 187 insertions, 0 deletions
diff --git a/media-libs/tse3/Manifest b/media-libs/tse3/Manifest
new file mode 100644
index 000000000000..6283b3f2b690
--- /dev/null
+++ b/media-libs/tse3/Manifest
@@ -0,0 +1,2 @@
+DIST tse3-0.3.1-awe_voice.h.tbz2 5681 SHA256 46167594fbdee44933fb7be0d5ae56c27ab1d107bd6cae6fab7b5d4dcafc88b5
+DIST tse3-0.3.1.tar.gz 755666 SHA256 780e1669789e762f489029c53f2fc6c571ba24740290ed0717bc1dcb7d547ba6
diff --git a/media-libs/tse3/files/tse3-0.2.7-gcc4.patch b/media-libs/tse3/files/tse3-0.2.7-gcc4.patch
new file mode 100644
index 000000000000..ed92ded207ab
--- /dev/null
+++ b/media-libs/tse3/files/tse3-0.2.7-gcc4.patch
@@ -0,0 +1,10 @@
+--- ./src/tse3/cmd/Phrase.h~ 2002-07-28 17:17:11.000000000 +0200
++++ ./src/tse3/cmd/Phrase.h 2005-07-29 15:45:03.000000000 +0200
+@@ -19,6 +19,7 @@
+
+ #include "tse3/cmd/Command.h"
+ #include "tse3/Phrase.h"
++#include "tse3/PhraseEdit.h"
+ #include "tse3/DisplayParams.h"
+
+ #include <vector>
diff --git a/media-libs/tse3/files/tse3-0.2.7-size_t-64bit.patch b/media-libs/tse3/files/tse3-0.2.7-size_t-64bit.patch
new file mode 100644
index 000000000000..29c54edc084f
--- /dev/null
+++ b/media-libs/tse3/files/tse3-0.2.7-size_t-64bit.patch
@@ -0,0 +1,25 @@
+--- src/tse3/file/XML.h.orig 2002-07-28 18:17:11.000000000 +0300
++++ src/tse3/file/XML.h 2004-04-25 14:51:56.000000000 +0300
+@@ -154,6 +154,7 @@
+ void element(const std::string &name, const char *value);
+ void element(const std::string &name, int value);
+ void element(const std::string &name, unsigned int value);
++ void element(const std::string &name, unsigned long value);
+ void element(const std::string &name, bool value);
+
+ void comment(const std::string &comment);
+--- src/tse3/file/XML.cpp.orig 2002-07-28 18:17:11.000000000 +0300
++++ src/tse3/file/XML.cpp 2004-04-25 14:54:01.000000000 +0300
+@@ -116,6 +116,12 @@
+ out << "<" << name << " value=\"" << value << "\"/>\n";
+ }
+
++void TSE3::File::XmlFileWriter::element(const std::string &name, unsigned long value)
++{
++ indent(out);
++ out << "<" << name << " value=\"" << value << "\"/>\n";
++}
++
+
+ void TSE3::File::XmlFileWriter::element(const std::string &name, bool value)
+ {
diff --git a/media-libs/tse3/files/tse3-0.3.1+gcc-4.3.patch b/media-libs/tse3/files/tse3-0.3.1+gcc-4.3.patch
new file mode 100644
index 000000000000..4581da9d0bf7
--- /dev/null
+++ b/media-libs/tse3/files/tse3-0.3.1+gcc-4.3.patch
@@ -0,0 +1,80 @@
+--- src/tse3/Serializable.h.orig 2008-06-08 12:17:05.000000000 +0200
++++ src/tse3/Serializable.h 2008-06-08 12:17:27.000000000 +0200
+@@ -20,6 +20,7 @@
+ #include <iosfwd>
+ #include <iomanip>
+ #include <cstddef>
++#include <fstream>
+
+ namespace TSE3
+ {
+
+--- src/tse3/TSE2MDL.h.orig 2008-06-08 12:17:41.000000000 +0200
++++ src/tse3/TSE2MDL.h 2008-06-08 12:18:02.000000000 +0200
+@@ -22,6 +22,7 @@
+ #include <string>
+ #include <iostream>
+ #include <cstddef>
++#include <cstring>
+
+ namespace TSE3
+ {
+
+--- src/tse3/MidiFile.h.orig 2008-06-08 12:18:26.000000000 +0200
++++ src/tse3/MidiFile.h 2008-06-08 12:18:42.000000000 +0200
+@@ -25,6 +25,7 @@
+ #include <string>
+ #include <iosfwd>
+ #include <cstddef>
++#include <cstring>
+
+ namespace TSE3
+ {
+--- src/examples/recording/recording.cpp.orig 2008-06-08 12:18:56.000000000 +0200
++++ src/examples/recording/recording.cpp 2008-06-08 12:19:18.000000000 +0200
+@@ -26,6 +26,7 @@
+ *
+ **************************************************************/
+
++#include <cstdlib>
+ #include <iostream>
+
+ // Used in step 1
+
+--- src/tse3play/tse3play.h.orig 2008-06-08 12:19:34.000000000 +0200
++++ src/tse3play/tse3play.h 2008-06-08 12:19:53.000000000 +0200
+@@ -19,6 +19,7 @@
+
+ #include <string>
+ #include <list>
++#include <cstdlib>
+
+ #include "tse3/Transport.h"
+
+--- src/tse3/plt/Alsa-0.9.cpp.orig 2008-06-08 12:39:53.000000000 +0200
++++ src/tse3/plt/Alsa-0.9.cpp 2008-06-08 12:40:25.000000000 +0200
+@@ -25,12 +25,11 @@
+ #define HAVE_SYS_ASOUNDLIB_H
+ #endif
+
+-#define _GNU_SOURCE
+ #include <sys/stat.h>
+ #include <errno.h>
+ #include <alloca.h>
+ #if HAVE_ALSA_ASOUNDLIB_H
+-#include <sys/asoundlib.h>
++#include <alsa/asoundlib.h>
+ #elif HAVE_SYS_ASOUNDLIB_H
+ #include <sys/asoundlib.h>
+ #endif
+
+--- src/tse3/plt/OSS.h.orig 2008-06-08 12:45:46.000000000 +0200
++++ src/tse3/plt/OSS.h 2008-06-08 12:46:06.000000000 +0200
+@@ -21,6 +21,7 @@
+
+ #include <string>
+ #include <list>
++#include <cstring>
+
+ #ifdef HAVE_CONFIG_H
+ #include "config.h"
diff --git a/media-libs/tse3/files/tse3-0.3.1-parallelmake.patch b/media-libs/tse3/files/tse3-0.3.1-parallelmake.patch
new file mode 100644
index 000000000000..b4fc927a7183
--- /dev/null
+++ b/media-libs/tse3/files/tse3-0.3.1-parallelmake.patch
@@ -0,0 +1,11 @@
+--- src/tse3/Makefile.am.old 2007-02-06 23:57:38.000000000 +0100
++++ src/tse3/Makefile.am 2007-02-07 00:08:01.000000000 +0100
+@@ -53,7 +53,7 @@
+
+ noinst_PROGRAMS = test
+ test_SOURCES = test.cpp
+-test_LDADD = $(top_builddir)/src/tse3/libtse3.la
++test_LDADD = ./libtse3.la
+
+ # McCabe .i file generation
+
diff --git a/media-libs/tse3/metadata.xml b/media-libs/tse3/metadata.xml
new file mode 100644
index 000000000000..715950308ec2
--- /dev/null
+++ b/media-libs/tse3/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">tse3</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-libs/tse3/tse3-0.3.1-r1.ebuild b/media-libs/tse3/tse3-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..0d16b5d99a03
--- /dev/null
+++ b/media-libs/tse3/tse3-0.3.1-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="TSE3 Sequencer library"
+HOMEPAGE="http://TSE3.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ mirror://gentoo/${P}-awe_voice.h.tbz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE="alsa oss"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ if use oss; then
+ cp "${WORKDIR}"/awe_voice.h src/
+ append-flags -DHAVE_AWE_VOICE_H
+ fi
+
+ epatch "${FILESDIR}"/${PN}-0.2.7-size_t-64bit.patch \
+ "${FILESDIR}"/${PN}-0.2.7-gcc4.patch \
+ "${FILESDIR}"/${P}-parallelmake.patch \
+ "${FILESDIR}"/${P}+gcc-4.3.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ use alsa || myconf="${myconf} --without-alsa"
+ use oss || myconf="${myconf} --without-oss"
+
+ econf \
+ --without-doc-install \
+ --without-aRts \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS NEWS README THANKS TODO doc/History
+ dohtml doc/*.{html,gif,png}
+}