summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2017-09-14 14:23:53 -0500
committerMatthias Maier <tamiko@gentoo.org>2017-09-14 14:24:18 -0500
commitc8d9adf62818774ab04531fb4f411c353891a54e (patch)
tree867e38c5f1cd49d85d4420173021afb82446e2a5 /media-libs/vigra
parentpackage.mask: Mask <sys-devel/binutils-2.28.1 (various sec bugs) (diff)
downloadgentoo-c8d9adf62818774ab04531fb4f411c353891a54e.tar.gz
gentoo-c8d9adf62818774ab04531fb4f411c353891a54e.tar.bz2
gentoo-c8d9adf62818774ab04531fb4f411c353891a54e.zip
media-libs/vigra: gcc-7 patch, bug #618172
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'media-libs/vigra')
-rw-r--r--media-libs/vigra/files/vigra-1.11.0-gcc-7.patch13
-rw-r--r--media-libs/vigra/vigra-1.11.0.ebuild6
2 files changed, 17 insertions, 2 deletions
diff --git a/media-libs/vigra/files/vigra-1.11.0-gcc-7.patch b/media-libs/vigra/files/vigra-1.11.0-gcc-7.patch
new file mode 100644
index 000000000000..4aaba64ed5e9
--- /dev/null
+++ b/media-libs/vigra/files/vigra-1.11.0-gcc-7.patch
@@ -0,0 +1,13 @@
+diff --git a/include/vigra/imagecontainer.hxx b/include/vigra/imagecontainer.hxx
+index a6f0f80..636cc64 100644
+--- a/include/vigra/imagecontainer.hxx
++++ b/include/vigra/imagecontainer.hxx
+@@ -763,7 +763,7 @@ public:
+ /** swap contents of this array with the contents of other
+ (STL-Container interface)
+ */
+- void swap(const ImagePyramid<ImageType, Alloc> &other)
++ void swap(ImagePyramid<ImageType, Alloc> &other)
+ {
+ images_.swap(other.images_);
+ std::swap(lowestLevel_, other.lowestLevel_);
diff --git a/media-libs/vigra/vigra-1.11.0.ebuild b/media-libs/vigra/vigra-1.11.0.ebuild
index 7727e5e430cd..2a8cb7118127 100644
--- a/media-libs/vigra/vigra-1.11.0.ebuild
+++ b/media-libs/vigra/vigra-1.11.0.ebuild
@@ -44,13 +44,15 @@ REQUIRED_USE="
DOCS=( README.md )
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc-7.patch
+)
+
pkg_setup() {
use python && python_setup
}
src_prepare() {
- default
-
einfo "Removing shipped docs and VCS files"
rm -rf doc || die
rm .git* .travis.yml || die