summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2018-11-29 21:20:38 -0500
committerNick Sarnie <sarnex@gentoo.org>2018-11-29 21:45:49 -0500
commit0afebfab2d262b6cfaf5c6948450a73dc3f45f1c (patch)
tree7ed4ef2fc73f05cf42c924c769aa35a887a52a76 /media-libs/vulkan-loader/vulkan-loader-1.1.92.1.ebuild
parentmedia-libs/vulkan-layers: Drop old (diff)
downloadgentoo-0afebfab2d262b6cfaf5c6948450a73dc3f45f1c.tar.gz
gentoo-0afebfab2d262b6cfaf5c6948450a73dc3f45f1c.tar.bz2
gentoo-0afebfab2d262b6cfaf5c6948450a73dc3f45f1c.zip
media-libs/vulkan-loader: Bump to 1.1.92.1
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
Diffstat (limited to 'media-libs/vulkan-loader/vulkan-loader-1.1.92.1.ebuild')
-rw-r--r--media-libs/vulkan-loader/vulkan-loader-1.1.92.1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/media-libs/vulkan-loader/vulkan-loader-1.1.92.1.ebuild b/media-libs/vulkan-loader/vulkan-loader-1.1.92.1.ebuild
new file mode 100644
index 000000000000..1cc42372829a
--- /dev/null
+++ b/media-libs/vulkan-loader/vulkan-loader-1.1.92.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/KhronosGroup/Vulkan-Loader.git"
+ EGIT_SUBMODULES=()
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="4cd7e44fc1ca6c4d8361720b43a3588ddf9fc4b6"
+ SRC_URI="https://github.com/KhronosGroup/Vulkan-Loader/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/Vulkan-Loader-${EGIT_COMMIT}"
+fi
+
+inherit python-any-r1 cmake-multilib
+
+DESCRIPTION="Vulkan Installable Client Driver (ICD) Loader"
+HOMEPAGE="https://github.com/KhronosGroup/Vulkan-Loader"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="layers wayland X"
+
+PDEPEND="layers? ( media-libs/vulkan-layers:=[${MULTILIB_USEDEP}] )"
+DEPEND="${PYTHON_DEPS}
+ >=dev-util/vulkan-headers-1.1.92.0
+ wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
+ X? (
+ x11-libs/libX11:=[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr:=[${MULTILIB_USEDEP}]
+ )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_SKIP_RPATH=True
+ -DBUILD_TESTS=False
+ -DBUILD_LOADER=True
+ -DBUILD_WSI_MIR_SUPPORT=False
+ -DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
+ -DBUILD_WSI_XCB_SUPPORT=$(usex X)
+ -DBUILD_WSI_XLIB_SUPPORT=$(usex X)
+ -DVULKAN_HEADERS_INSTALL_DIR="/usr"
+ )
+ cmake-utils_src_configure
+}
+
+multilib_src_install() {
+ keepdir /etc/vulkan/icd.d
+
+ cmake-utils_src_install
+}
+
+pkg_postinst() {
+ einfo "USE=demos has been dropped as per upstream packaging"
+ einfo "vulkaninfo is now available in the dev-util/vulkan-tools package"
+}