summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2014-07-28 20:12:43 +0200
committerBertrand Jacquin <bertrand@jacquin.bzh>2015-10-14 00:26:19 +0100
commit5658f1dc7a9c128630e2c4b0b843ecfd14cbf592 (patch)
tree123839cd3847179ca09c717b0a887d04331df268 /media-libs/x265/files
parentprofiles/package.mask: remove old openrc-0.18.1 mask (diff)
downloadgentoo-5658f1dc7a9c128630e2c4b0b843ecfd14cbf592.tar.gz
gentoo-5658f1dc7a9c128630e2c4b0b843ecfd14cbf592.tar.bz2
gentoo-5658f1dc7a9c128630e2c4b0b843ecfd14cbf592.zip
media-libs/x265: Fix x32 build, bug #510890
x32 arch as defined on https://sites.google.com/site/x32abi is neither X86 nor X64, then forcing -march=i686 leads to build failure as wrong -march is used. Forcing -march, -mfloat-abi and -mfpu for ARM is also wrong As a global sanity sake, disable all forced -march in CMakeLists Upstream report: https://bitbucket.org/multicoreware/x265/pull-requests/21/build-disable-march-selection-from/diff Package-Manager: portage-2.2.20.1
Diffstat (limited to 'media-libs/x265/files')
-rw-r--r--media-libs/x265/files/1.8-build-Disable-march-selection-from-CMakeLists.txt.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-libs/x265/files/1.8-build-Disable-march-selection-from-CMakeLists.txt.patch b/media-libs/x265/files/1.8-build-Disable-march-selection-from-CMakeLists.txt.patch
new file mode 100644
index 000000000000..33ee254661cf
--- /dev/null
+++ b/media-libs/x265/files/1.8-build-Disable-march-selection-from-CMakeLists.txt.patch
@@ -0,0 +1,35 @@
+From e89069148db716d30fb81c798d0cfd83250a9f5a Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Sat, 10 Oct 2015 00:05:41 +0100
+Subject: [PATCH] build: Disable -march selection from CMakeLists.txt
+
+x32 arch as defined on https://sites.google.com/site/x32abi is neither
+X86 nor X64, then forcing -march=i686 leads to build failure as wrong
+-march is used.
+
+Forcing -march, -mfloat-abi and -mfpu for ARM is also wrong
+
+As a global sanity sake, disable all forced -march in CMakeLists
+---
+ source/CMakeLists.txt | 7 -------
+ 1 file changed, 7 deletions(-)
+
+diff --git a/source/CMakeLists.txt b/source/CMakeLists.txt
+index 764d5f2..fbc0d49 100644
+--- a/source/CMakeLists.txt
++++ b/source/CMakeLists.txt
+@@ -167,14 +167,7 @@ if(GCC)
+ if(NATIVE_BUILD)
+ if(INTEL_CXX)
+ add_definitions(-xhost)
+- else()
+- add_definitions(-march=native)
+ endif()
+- elseif(X86 AND NOT X64)
+- add_definitions(-march=i686)
+- endif()
+- if(ARM)
+- add_definitions(-march=armv6 -mfloat-abi=hard -mfpu=vfp)
+ endif()
+ if(FPROFILE_GENERATE)
+ if(INTEL_CXX)