summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-05-24 22:02:39 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-05-24 22:09:58 -0700
commitfe5c3453d9b642af66fbbc09c9b0e844034bc21f (patch)
treeb2c4b5e0b0c850a4d96a71329268498a36dbff45 /media-libs/x265/x265-9999.ebuild
parentmedia-libs/x265: fix 3.3 on ppc64 (diff)
downloadgentoo-fe5c3453d9b642af66fbbc09c9b0e844034bc21f.tar.gz
gentoo-fe5c3453d9b642af66fbbc09c9b0e844034bc21f.tar.bz2
gentoo-fe5c3453d9b642af66fbbc09c9b0e844034bc21f.zip
media-libs/x265: sync live ebuild
Bug: https://bugs.gentoo.org/725134 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'media-libs/x265/x265-9999.ebuild')
-rw-r--r--media-libs/x265/x265-9999.ebuild20
1 files changed, 16 insertions, 4 deletions
diff --git a/media-libs/x265/x265-9999.ebuild b/media-libs/x265/x265-9999.ebuild
index 96fa1f5e454c..736bea15bb84 100644
--- a/media-libs/x265/x265-9999.ebuild
+++ b/media-libs/x265/x265-9999.ebuild
@@ -88,6 +88,8 @@ x265_variant_src_configure() {
-DENABLE_CLI=OFF
-DMAIN12=ON
)
+ # disable altivec for 12bit build #607802#c5
+ [[ ${ABI} = ppc* ]] && mycmakeargs+=( -DENABLE_ALTIVEC=OFF )
;;
"main10")
mycmakeargs+=(
@@ -96,6 +98,8 @@ x265_variant_src_configure() {
-DENABLE_SHARED=OFF
-DENABLE_CLI=OFF
)
+ # disable altivec for 10bit build #607802#c5
+ [[ ${ABI} = ppc* ]] && mycmakeargs+=( -DENABLE_ALTIVEC=OFF )
;;
"main")
if (( "${#MULTIBUILD_VARIANTS[@]}" > 1 )) ; then
@@ -112,6 +116,14 @@ x265_variant_src_configure() {
-DLINKED_10BIT=$(usex 10bit)
-DLINKED_12BIT=$(usex 12bit)
)
+ # we have to handle ppc here and not in multilib_src_configure
+ # because we want those flags apply ONLY to "main" variant
+ if [[ ${ABI} = ppc* ]] ; then
+ myabicmakeargs+=(
+ -DCPU_POWER8=$(usex power8 ON OFF)
+ -DENABLE_ALTIVEC=$(usex cpu_flags_ppc_altivec ON OFF)
+ )
+ fi
fi
;;
*)
@@ -152,10 +164,10 @@ multilib_src_configure() {
supports_asm=no
fi
elif [[ ${ABI} = ppc* ]] ; then
- myabicmakeargs+=(
- -DCPU_POWER8=$(usex power8 ON OFF)
- -DENABLE_ALTIVEC=$(usex cpu_flags_ppc_altivec ON OFF)
- )
+ if use asm ; then
+ ewarn "ppc64 uses altivec instead of asm, disabling it."
+ supports_asm=no
+ fi
fi
if [[ "${supports_asm}" = yes ]] && use asm ; then