summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-07-08 10:10:57 +0200
committerTony Vroon <chainsaw@gentoo.org>2018-07-11 12:38:21 +0100
commit1688ed671ae14234075f79fce6428d141c31ba7b (patch)
treecab5a97bd06e002468807c22028e1263655acf04 /media-libs/xine-lib/files
parentmedia-gfx/openexr_viewers: remove unused patches (diff)
downloadgentoo-1688ed671ae14234075f79fce6428d141c31ba7b.tar.gz
gentoo-1688ed671ae14234075f79fce6428d141c31ba7b.tar.bz2
gentoo-1688ed671ae14234075f79fce6428d141c31ba7b.zip
media-libs/xine-lib: remove unused patches
Diffstat (limited to 'media-libs/xine-lib/files')
-rw-r--r--media-libs/xine-lib/files/ffmpeg29.patch44
-rw-r--r--media-libs/xine-lib/files/xine-lib-1.2.6-libxcb-1.12.patch25
-rw-r--r--media-libs/xine-lib/files/xine-lib-1.2.6-sysmacros.patch15
3 files changed, 0 insertions, 84 deletions
diff --git a/media-libs/xine-lib/files/ffmpeg29.patch b/media-libs/xine-lib/files/ffmpeg29.patch
deleted file mode 100644
index a220483218c0..000000000000
--- a/media-libs/xine-lib/files/ffmpeg29.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-Index: xine-lib-1.2.6/src/combined/ffmpeg/ff_audio_decoder.c
-===================================================================
---- xine-lib-1.2.6.orig/src/combined/ffmpeg/ff_audio_decoder.c
-+++ xine-lib-1.2.6/src/combined/ffmpeg/ff_audio_decoder.c
-@@ -590,7 +590,7 @@ static int ff_audio_decode (ff_audio_dec
- int got_frame;
- float gain = this->class->gain;
- if (!this->av_frame)
-- this->av_frame = avcodec_alloc_frame ();
-+ this->av_frame = av_frame_alloc ();
-
- consumed = avcodec_decode_audio4 (this->context, this->av_frame, &got_frame, &avpkt);
- if ((consumed >= 0) && got_frame) {
-@@ -1071,7 +1071,7 @@ static void ff_audio_reset (audio_decode
- /* try to reset the wma decoder */
- if( this->decoder_ok ) {
- #if AVAUDIO > 3
-- avcodec_free_frame (&this->av_frame);
-+ av_frame_free (&this->av_frame);
- #endif
- pthread_mutex_lock (&ffmpeg_lock);
- avcodec_close (this->context);
-@@ -1105,7 +1105,7 @@ static void ff_audio_dispose (audio_deco
-
- if( this->context && this->decoder_ok ) {
- #if AVAUDIO > 3
-- avcodec_free_frame (&this->av_frame);
-+ av_frame_free (&this->av_frame);
- #endif
- pthread_mutex_lock (&ffmpeg_lock);
- avcodec_close (this->context);
-Index: xine-lib-1.2.6/src/combined/ffmpeg/ff_video_decoder.c
-===================================================================
---- xine-lib-1.2.6.orig/src/combined/ffmpeg/ff_video_decoder.c
-+++ xine-lib-1.2.6/src/combined/ffmpeg/ff_video_decoder.c
-@@ -2523,7 +2523,7 @@ static video_decoder_t *ff_video_open_pl
- this->stream = stream;
- this->class = (ff_video_class_t *) class_gen;
-
-- this->av_frame = avcodec_alloc_frame();
-+ this->av_frame = av_frame_alloc();
- this->context = avcodec_alloc_context();
- this->context->opaque = this;
- #if AVPALETTE == 1
diff --git a/media-libs/xine-lib/files/xine-lib-1.2.6-libxcb-1.12.patch b/media-libs/xine-lib/files/xine-lib-1.2.6-libxcb-1.12.patch
deleted file mode 100644
index cc17643d9c56..000000000000
--- a/media-libs/xine-lib/files/xine-lib-1.2.6-libxcb-1.12.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-https://bugs.xine-project.org/show_bug.cgi?id=572
-https://bugs.gentoo.org/584640
-
---- xine-lib-1.2.6/m4/video_out.m4
-+++ xine-lib-1.2.6/m4/video_out.m4
-@@ -305,7 +305,7 @@
- dnl xcb
- XINE_ARG_WITH([xcb], [Enable support for XCB video out plugins])
- if test x"$with_xcb" != x"no"; then
-- PKG_CHECK_MODULES([XCB], [xcb-shape >= 1.0], [have_xcb=yes], [have_xcb=no])
-+ PKG_CHECK_MODULES([XCB], [xcb xcb-shape >= 1.0], [have_xcb=yes], [have_xcb=no])
- if test x"$hard_enable_xcb" = x"yes" && test x"$have_xcb" != x"yes"; then
- AC_MSG_ERROR([XCB support requested, but XCB not found])
- elif test x"$have_xcb" = x"yes"; then
---- xine-lib-1.2.6/src/video_out/Makefile.am
-+++ xine-lib-1.2.6/src/video_out/Makefile.am
-@@ -147,7 +147,7 @@
- xineplug_vo_out_xcbshm_la_CFLAGS = $(AM_CFLAGS) $(XCB_CFLAGS) $(XCBSHM_CFLAGS) $(AVUTIL_CFLAGS)
-
- xineplug_vo_out_xcbxv_la_SOURCES = video_out_xcbxv.c $(XCBOSD)
--xineplug_vo_out_xcbxv_la_LIBADD = $(XINE_LIB) $(PTHREAD_LIBS) $(LTLIBINTL) $(XCBXV_LIBS) $(XCB_LIBS)
-+xineplug_vo_out_xcbxv_la_LIBADD = $(XINE_LIB) $(PTHREAD_LIBS) $(LTLIBINTL) $(XCBXV_LIBS) $(XCBSHM_LIBS) $(XCB_LIBS)
- xineplug_vo_out_xcbxv_la_CFLAGS = $(AM_CFLAGS) $(XCB_CFLAGS) $(XCBXV_CFLAGS)
-
- xineplug_vo_out_xshm_la_SOURCES = video_out_xshm.c $(X11OSD)
diff --git a/media-libs/xine-lib/files/xine-lib-1.2.6-sysmacros.patch b/media-libs/xine-lib/files/xine-lib-1.2.6-sysmacros.patch
deleted file mode 100644
index a7168d5b4506..000000000000
--- a/media-libs/xine-lib/files/xine-lib-1.2.6-sysmacros.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-fix build w/newer glibc due to major/minor includes being dropped from sys/types.h
-
-https://bugs.gentoo.org/580012
-https://bugs.xine-project.org/show_bug.cgi?id=574
-
---- a/src/xine-utils/xine_check.c
-+++ b/src/xine-utils/xine_check.c
-@@ -55,6 +55,7 @@
- #include <dlfcn.h>
- #include <sys/stat.h>
- #include <sys/ioctl.h>
-+#include <sys/sysmacros.h>
- #include <sys/utsname.h>
- #include <linux/major.h>
- #include <linux/hdreg.h>