summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-07-17 09:20:01 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-07-17 09:20:30 +0200
commit858eec4083f3de171a9ba1d20a8354f30bded343 (patch)
treee2569223981bf1800b8479c3f9b39026b5a92555 /media-libs/zimg/zimg-2.7.5.ebuild
parentmedia-video/libva-utils: bump to 2.2.0 (diff)
downloadgentoo-858eec4083f3de171a9ba1d20a8354f30bded343.tar.gz
gentoo-858eec4083f3de171a9ba1d20a8354f30bded343.tar.bz2
gentoo-858eec4083f3de171a9ba1d20a8354f30bded343.zip
media-libs/zimg: bump to 2.7.5
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'media-libs/zimg/zimg-2.7.5.ebuild')
-rw-r--r--media-libs/zimg/zimg-2.7.5.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-libs/zimg/zimg-2.7.5.ebuild b/media-libs/zimg/zimg-2.7.5.ebuild
new file mode 100644
index 000000000000..fe1991fc9e05
--- /dev/null
+++ b/media-libs/zimg/zimg-2.7.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+
+SCM=""
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/sekrit-twc/zimg"
+fi
+
+inherit autotools-multilib ${SCM}
+
+DESCRIPTION="Scaling, colorspace conversion, and dithering library"
+HOMEPAGE="https://github.com/sekrit-twc/zimg"
+
+if [ "${PV#9999}" = "${PV}" ] ; then
+ SRC_URI="https://github.com/sekrit-twc/zimg/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+ S="${WORKDIR}/${PN}-release-${PV}/"
+fi
+
+LICENSE="WTFPL-2"
+SLOT="0"
+IUSE="static-libs cpu_flags_x86_sse"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ autotools-multilib_src_configure \
+ $(use_enable cpu_flags_x86_sse x86simd)
+}