summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-23 15:58:38 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-23 15:58:38 +0200
commit5214b1e9b7c1deba31d5a5e4b82002db478c0b1b (patch)
treec16a446daddf64bbd7c9745733ddf4f2b5e0adb8 /media-libs/zimg
parentmedia-libs/zimg: remove old (diff)
downloadgentoo-5214b1e9b7c1deba31d5a5e4b82002db478c0b1b.tar.gz
gentoo-5214b1e9b7c1deba31d5a5e4b82002db478c0b1b.tar.bz2
gentoo-5214b1e9b7c1deba31d5a5e4b82002db478c0b1b.zip
media-libs/zimg: bump to 2.5.1
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'media-libs/zimg')
-rw-r--r--media-libs/zimg/Manifest1
-rw-r--r--media-libs/zimg/zimg-2.5.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/zimg/Manifest b/media-libs/zimg/Manifest
index d002e4af8405..6a4583d130c0 100644
--- a/media-libs/zimg/Manifest
+++ b/media-libs/zimg/Manifest
@@ -1 +1,2 @@
+DIST zimg-2.5.1.tar.gz 213083 SHA256 deb85887081cab7fa9c492b588900d60d6466e61ee8ea51a84ca280688d93de9 SHA512 c16402ee7aff40b811cd8c69c1e5d5f13775e628f3d5300e82548b6cc97d17e5317fa58d498a0cb4f7699d4eb2d1f424c3f4d9858f4cfbdda36612d6693961a0 WHIRLPOOL 7dac4a8f305e471b10db50bd6f189d9591e2ca46ec008c7bec1e4d6f6b47f409dfeed575e5bc7a00678430e5a673196ab814c5c45b1afeb43145b33f8dcc63dc
DIST zimg-2.5.tar.gz 213054 SHA256 50b2bcc49e51cd36011a0c363ff914a81b6f161aefdffeaa2bc4a4627c13784d SHA512 7fc48c704b434d837c36d4bafc51b35789eaf90fc81a68dcd7ec546f1e82a3e41c53263f8d381541d5c0ce58e25dddf0adaf1c3575512842ae633b5581778938 WHIRLPOOL 38ec8b7c26b8b358551a8158372f0cf1d27fbb4a0666ec8b56c3b7227f18bda4267f252596eba5a26347463ef8426982c9befe2ccf9bb1384a17d393ff35390a
diff --git a/media-libs/zimg/zimg-2.5.1.ebuild b/media-libs/zimg/zimg-2.5.1.ebuild
new file mode 100644
index 000000000000..5826bad7c0df
--- /dev/null
+++ b/media-libs/zimg/zimg-2.5.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+
+SCM=""
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/sekrit-twc/zimg"
+fi
+
+inherit autotools-multilib ${SCM}
+
+DESCRIPTION="Scaling, colorspace conversion, and dithering library"
+HOMEPAGE="https://github.com/sekrit-twc/zimg"
+
+if [ "${PV#9999}" = "${PV}" ] ; then
+ SRC_URI="https://github.com/sekrit-twc/zimg/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~x86"
+ S="${WORKDIR}/${PN}-release-${PV}/"
+fi
+
+LICENSE="WTFPL-2"
+SLOT="0"
+IUSE="static-libs cpu_flags_x86_sse"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ autotools-multilib_src_configure \
+ $(use_enable cpu_flags_x86_sse x86simd)
+}