summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Tsoy <alexander@tsoy.me>2019-04-16 00:22:22 +0300
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-04-20 22:01:25 -0700
commitdbd7f030d482f5593d4fb1d5c4ebcaf633f3174f (patch)
tree96aca3561dc718357ebd94f715f0c803ade19a94 /media-libs/zita-resampler/zita-resampler-1.6.2.ebuild
parentapp-misc/uptimed: amd64 stable wrt bug #683918 (diff)
downloadgentoo-dbd7f030d482f5593d4fb1d5c4ebcaf633f3174f.tar.gz
gentoo-dbd7f030d482f5593d4fb1d5c4ebcaf633f3174f.tar.bz2
gentoo-dbd7f030d482f5593d4fb1d5c4ebcaf633f3174f.zip
media-libs/zita-resampler: new package
Libzita-resampler is a C++ library for resampling audio signals. It is designed to be used within a real-time processing context, to be fast, and to provide high-quality sample rate conversion. Dependency of media-sound/guitarix Signed-off-by: Alexander Tsoy <alexander@tsoy.me> Package-Manager: Portage-2.3.62, Repoman-2.3.11 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'media-libs/zita-resampler/zita-resampler-1.6.2.ebuild')
-rw-r--r--media-libs/zita-resampler/zita-resampler-1.6.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-libs/zita-resampler/zita-resampler-1.6.2.ebuild b/media-libs/zita-resampler/zita-resampler-1.6.2.ebuild
new file mode 100644
index 000000000000..754fa1dfdde9
--- /dev/null
+++ b/media-libs/zita-resampler/zita-resampler-1.6.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="C++ library for real-time resampling of audio signals"
+HOMEPAGE="http://kokkinizita.linuxaudio.org/linuxaudio/"
+SRC_URI="http://kokkinizita.linuxaudio.org/linuxaudio/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0/1"
+KEYWORDS="~amd64"
+IUSE="tools"
+
+RDEPEND="tools? ( media-libs/libsndfile )"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+HTML_DOCS="docs/."
+
+PATCHES=( "${FILESDIR}"/${PN}-1.6.2-makefile.patch )
+
+src_compile() {
+ tc-export CXX
+
+ emake -C source
+ if use tools; then
+ emake -C apps
+ fi
+}
+
+src_install() {
+ emake -C source DESTDIR="${D}" PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}"/usr/$(get_libdir) install
+ if use tools; then
+ emake -C apps DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ fi
+
+ einstalldocs
+}