summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Tsoy <alexander@tsoy.me>2021-01-05 20:10:49 +0300
committerMiroslav Šulc <fordfrog@gentoo.org>2021-01-06 10:10:45 +0100
commitef090ee489fb4b51afefc4495df5349e0343eb44 (patch)
tree316ffd696fbe55f320e474c97f86223ac58ef2cd /media-libs/zita-resampler
parentdev-java/tomcat-native: bump to 1.2.26 (diff)
downloadgentoo-ef090ee489fb4b51afefc4495df5349e0343eb44.tar.gz
gentoo-ef090ee489fb4b51afefc4495df5349e0343eb44.tar.bz2
gentoo-ef090ee489fb4b51afefc4495df5349e0343eb44.zip
media-libs/zita-resampler: Version bump to 1.8.0
Signed-off-by: Alexander Tsoy <alexander@tsoy.me> Closes: https://github.com/gentoo/gentoo/pull/18958 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-libs/zita-resampler')
-rw-r--r--media-libs/zita-resampler/Manifest1
-rw-r--r--media-libs/zita-resampler/files/zita-resampler-1.8.0-makefile.patch91
-rw-r--r--media-libs/zita-resampler/zita-resampler-1.8.0.ebuild44
3 files changed, 136 insertions, 0 deletions
diff --git a/media-libs/zita-resampler/Manifest b/media-libs/zita-resampler/Manifest
index 60d50f605c7c..48a5cd2b9812 100644
--- a/media-libs/zita-resampler/Manifest
+++ b/media-libs/zita-resampler/Manifest
@@ -1 +1,2 @@
DIST zita-resampler-1.6.2.tar.bz2 125539 BLAKE2B d2e04fb5e0efbde3432ce973df59a11d2a184146d124b662712a5de2d9c243f6564899f190f7a7b68a9e01bcaab05c92b91ebcbf942473134a12a85e4e08c603 SHA512 d547419dd222c8a399d8f196efa1ec88a3f781275b696ae2fe1bb6e2fc329285affb8aace85972c304ad256becc4a155534dd5ef4ce3c57cbc9dcca0122b670c
+DIST zita-resampler-1.8.0.tar.bz2 131161 BLAKE2B 1ba5d255fff9c66e18e6177bc7e48a4710fdf54f58c07f162f8c8801f4f449b22dea9922645e7e33b70e07739c2b381176714e704f9840305f194f3c23d66de2 SHA512 adf1f465ac09104be5a02c1cf0f052a44b4c1a448312f3aca016a889e98cfcdebfded38f60300ad85d18ae03eadca7e8e95efb2875267bc36435ccfac881a8e7
diff --git a/media-libs/zita-resampler/files/zita-resampler-1.8.0-makefile.patch b/media-libs/zita-resampler/files/zita-resampler-1.8.0-makefile.patch
new file mode 100644
index 000000000000..860e199a51de
--- /dev/null
+++ b/media-libs/zita-resampler/files/zita-resampler-1.8.0-makefile.patch
@@ -0,0 +1,91 @@
+diff -urpN zita-resampler-1.8.0.orig/apps/Makefile zita-resampler-1.8.0/apps/Makefile
+--- zita-resampler-1.8.0.orig/apps/Makefile 2018-08-23 12:52:50.000000000 +0300
++++ zita-resampler-1.8.0/apps/Makefile 2021-01-05 20:27:20.816636061 +0300
+@@ -23,18 +23,17 @@ BINDIR ?= $(PREFIX)/bin
+ MANDIR ?= /usr/share/man/man1
+
+ VERSION = 1.6.0
+-CPPFLAGS += -MMD -MP -DVERSION=\"$(VERSION)\"
+-CXXFLAGS += -O2 -ffast-math -Wall
+-CXXFLAGS += -march=native
++CPPFLAGS += -MMD -MP -DVERSION=\"$(VERSION)\" -I ../source
++CXXFLAGS += -ffast-math -Wall
+
+
+-all: zresample zretune zresample.1.gz zretune.1.gz
++all: zresample zretune
+
+
+ ZRESAMPLE_O = zresample.o audiofile.o dither.o
+ zresample: LDLIBS += -lzita-resampler -lsndfile -lrt
+ zresample: $(ZRESAMPLE_O)
+- $(CXX) $(LDFLAGS) -o $@ $(ZRESAMPLE_O) $(LDLIBS)
++ $(CXX) -L ../source $(LDFLAGS) -o $@ $(ZRESAMPLE_O) $(LDLIBS)
+ $(ZRESAMPLE_O):
+ -include $(ZRESAMPLE_O:%.o=%.d)
+
+@@ -42,25 +41,18 @@ $(ZRESAMPLE_O):
+ ZRETUNE_O = zretune.o audiofile.o dither.o
+ zretune: LDLIBS += -lzita-resampler -lsndfile -lrt
+ zretune: $(ZRETUNE_O)
+- $(CXX) $(LDFLAGS) -o $@ $(ZRETUNE_O) $(LDLIBS)
++ $(CXX) -L ../source $(LDFLAGS) -o $@ $(ZRETUNE_O) $(LDLIBS)
+ $(ZRETUNE_O):
+ -include $(ZRETUNE_O:%.o=%.d)
+
+
+-zresample.1.gz: zresample.1
+- gzip -c zresample.1 > zresample.1.gz
+-
+-zretune.1.gz: zretune.1
+- gzip -c zretune.1 > zretune.1.gz
+-
+-
+ install: all
+- install -d $(BINDIR)
+- install -d $(MANDIR)
++ install -d $(DESTDIR)$(BINDIR)
++ install -d $(DESTDIR)$(MANDIR)
+ install -m 755 zresample $(DESTDIR)$(BINDIR)
+ install -m 755 zretune $(DESTDIR)$(BINDIR)
+- install -m 644 zresample.1.gz $(DESTDIR)$(MANDIR)
+- install -m 644 zretune.1.gz $(DESTDIR)$(MANDIR)
++ install -m 644 zresample.1 $(DESTDIR)$(MANDIR)
++ install -m 644 zretune.1 $(DESTDIR)$(MANDIR)
+
+ uninstall:
+ /bin/rm -f $(DESTDIR)$(BINDIR)/zresample
+diff -urpN zita-resampler-1.8.0.orig/source/Makefile zita-resampler-1.8.0/source/Makefile
+--- zita-resampler-1.8.0.orig/source/Makefile 2020-12-28 23:09:24.000000000 +0300
++++ zita-resampler-1.8.0/source/Makefile 2021-01-05 20:19:47.951831754 +0300
+@@ -31,9 +31,7 @@ VERSION = $(MAJVERS).$(MINVERS)
+ DISTDIR = zita-resampler-$(VERSION)
+
+ CPPFLAGS += -I. -D_REENTRANT -D_POSIX_PTHREAD_SEMANTICS
+-CPPFLAGS += -DENABLE_SSE2
+-CXXFLAGS += -Wall -fPIC -O2 -ffast-math
+-CXXFLAGS += -march=native
++CXXFLAGS += -Wall -fPIC -ffast-math
+ LDFLAGS +=
+ LDLIBS +=
+
+@@ -47,6 +45,9 @@ ZITA-RESAMPLER_H = zita-resampler/resamp
+ zita-resampler/vresampler.h zita-resampler/cresampler.h
+
+
++$(ZITA-RESAMPLER_SO): $(ZITA-RESAMPLER_MIN)
++ ln -sf $(ZITA-RESAMPLER_MIN) $(ZITA-RESAMPLER_SO)
++
+ $(ZITA-RESAMPLER_MIN): $(ZITA-RESAMPLER_O)
+ $(CXX) -shared $(LDFLAGS) -Wl,-soname,$(ZITA-RESAMPLER_MAJ) -o $(ZITA-RESAMPLER_MIN) $(ZITA-RESAMPLER_O) $(ZITA-RESAMPLER_DEP)
+
+@@ -58,8 +59,8 @@ install: $(ZITA-RESAMPLER_MIN)
+ install -d $(DESTDIR)$(LIBDIR)
+ install -m 644 $(ZITA-RESAMPLER_H) $(DESTDIR)$(INCDIR)/zita-resampler
+ install -m 755 $(ZITA-RESAMPLER_MIN) $(DESTDIR)$(LIBDIR)
+- ldconfig
+ ln -sf $(ZITA-RESAMPLER_MIN) $(DESTDIR)$(LIBDIR)/$(ZITA-RESAMPLER_SO)
++ ln -sf $(ZITA-RESAMPLER_MIN) $(DESTDIR)$(LIBDIR)/$(ZITA-RESAMPLER_MAJ)
+
+ uninstall:
+ /bin/rm -rf $(DESTDIR)$(INCDIR)/zita-resampler
diff --git a/media-libs/zita-resampler/zita-resampler-1.8.0.ebuild b/media-libs/zita-resampler/zita-resampler-1.8.0.ebuild
new file mode 100644
index 000000000000..b23f36961060
--- /dev/null
+++ b/media-libs/zita-resampler/zita-resampler-1.8.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="C++ library for real-time resampling of audio signals"
+HOMEPAGE="http://kokkinizita.linuxaudio.org/linuxaudio/"
+SRC_URI="http://kokkinizita.linuxaudio.org/linuxaudio/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cpu_flags_x86_sse2 tools"
+
+RDEPEND="tools? ( media-libs/libsndfile )"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+HTML_DOCS="docs/."
+
+PATCHES=( "${FILESDIR}"/${PN}-1.8.0-makefile.patch )
+
+src_compile() {
+ tc-export CXX
+ if use cpu_flags_x86_sse2 ; then
+ append-cppflags "-DENABLE_SSE2"
+ fi
+
+ emake -C source
+ if use tools; then
+ emake -C apps
+ fi
+}
+
+src_install() {
+ emake -C source DESTDIR="${D}" PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}"/usr/$(get_libdir) install
+ if use tools; then
+ emake -C apps DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ fi
+
+ einstalldocs
+}