summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2020-10-31 10:51:13 -0400
committerJames Le Cuirot <chewi@gentoo.org>2020-11-01 22:01:40 +0000
commitfb351619780cd717b03567145b5f94afc7f966ce (patch)
tree98127e1e9e945ce04507bc2ced7146d77a556ba1 /media-libs/zmusic/zmusic-1.1.4.ebuild
parentapp-emulation/libvirt: default-enable USE=virt-network (diff)
downloadgentoo-fb351619780cd717b03567145b5f94afc7f966ce.tar.gz
gentoo-fb351619780cd717b03567145b5f94afc7f966ce.tar.bz2
gentoo-fb351619780cd717b03567145b5f94afc7f966ce.zip
media-libs/zmusic: version bump to 1.1.4
Closes: https://bugs.gentoo.org/740752 Closes: https://bugs.gentoo.org/752033 Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/18091 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-libs/zmusic/zmusic-1.1.4.ebuild')
-rw-r--r--media-libs/zmusic/zmusic-1.1.4.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/media-libs/zmusic/zmusic-1.1.4.ebuild b/media-libs/zmusic/zmusic-1.1.4.ebuild
new file mode 100644
index 000000000000..221e294349f7
--- /dev/null
+++ b/media-libs/zmusic/zmusic-1.1.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+MY_PN="ZMusic"
+DESCRIPTION="GZDoom's music system as a standalone library"
+HOMEPAGE="https://github.com/coelckers/ZMusic"
+SRC_URI="https://github.com/coelckers/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD DUMB-0.9.3 GPL-3 LGPL-2.1+ LGPL-3 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="alsa fluidsynth mpg123 +sndfile"
+
+DEPEND="
+ sys-libs/zlib
+ alsa? ( media-libs/alsa-lib )
+ fluidsynth? ( media-sound/fluidsynth:= )
+ mpg123? ( media-sound/mpg123 )
+ sndfile? ( media-libs/libsndfile )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ rm -rf licenses || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DFORCE_INTERNAL_ZLIB=OFF
+ -DFORCE_INTERNAL_GME=ON
+ -DDYN_FLUIDSYNTH=OFF
+ -DDYN_SNDFILE=OFF
+ -DDYN_MPG123=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_ALSA="$(usex !alsa)"
+ -DCMAKE_DISABLE_FIND_PACKAGE_FluidSynth="$(usex !fluidsynth)"
+ -DCMAKE_DISABLE_FIND_PACKAGE_MPG123="$(usex !mpg123)"
+ -DCMAKE_DISABLE_FIND_PACKAGE_SndFile="$(usex !sndfile)"
+ -DBUILD_SHARED_LIBS=ON
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+}