summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-05-30 13:49:24 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-05-30 13:56:06 +0200
commit037cb9b2ac6bfb4c649099b043dfee2a71a8f80f (patch)
tree02fc4924ab3343256e8bce74e36ab8e314ba695b /media-libs/zxing-cpp
parentsci-mathematics/singular: remove outdated versions and patches. (diff)
downloadgentoo-037cb9b2ac6bfb4c649099b043dfee2a71a8f80f.tar.gz
gentoo-037cb9b2ac6bfb4c649099b043dfee2a71a8f80f.tar.bz2
gentoo-037cb9b2ac6bfb4c649099b043dfee2a71a8f80f.zip
media-libs/zxing-cpp: 1.2.0 version bump
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/zxing-cpp')
-rw-r--r--media-libs/zxing-cpp/Manifest1
-rw-r--r--media-libs/zxing-cpp/zxing-cpp-1.2.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/media-libs/zxing-cpp/Manifest b/media-libs/zxing-cpp/Manifest
index 89bbfcd76caa..833baebc4c53 100644
--- a/media-libs/zxing-cpp/Manifest
+++ b/media-libs/zxing-cpp/Manifest
@@ -1 +1,2 @@
DIST zxing-cpp-1.1.1.tar.gz 128925736 BLAKE2B d2d6b4b13c26ee1bf8c9f1188809207f895d9ab4bde83e7e06d85d7105c56021bb9f82f34b9f11e1c8ff5b82825de127d1bc873745fa6ef603a8d206f3eaedec SHA512 c7d97df147602e31e58eede54413814378895e9710cf266de984b22965a9a3f4c67648a0bf936a8bc8b213b45def59d1e5b34d6ce516265333dd2c0430554dc7
+DIST zxing-cpp-1.2.0.tar.gz 97942494 BLAKE2B dc220783fe8a9c1ea321ad5b7835553985a06318f909af1574131b55f3a4bb71f8cf90f56925dfe8338df5cc24f91d93d8a7626cd8d2c01473b1ccce09bad8b0 SHA512 e61b4e44ccaf0871b5d8badf9ce0a81576f55e5d6a9458907b9b599a66227adceabb8d51a0c47b32319d8aeff93e758b4785d3bd0440375247471d95999de487
diff --git a/media-libs/zxing-cpp/zxing-cpp-1.2.0.ebuild b/media-libs/zxing-cpp/zxing-cpp-1.2.0.ebuild
new file mode 100644
index 000000000000..8f32a4b24e1d
--- /dev/null
+++ b/media-libs/zxing-cpp/zxing-cpp-1.2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="C++ Multi-format 1D/2D barcode image processing library"
+HOMEPAGE="https://github.com/nu-book/zxing-cpp"
+SRC_URI="https://github.com/nu-book/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_EXAMPLES=OFF # nothing is installed
+ -DBUILD_BLACKBOX_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}