summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-05-02 09:28:41 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-05-02 09:28:55 +0200
commit2a78e7f1bfd34a0f1ac7710725077999c06805e0 (patch)
treeb8451f23ce495a8a89467fcd022ccbfc1d629e23 /media-libs/zxing-cpp
parentsys-cluster/k3s: 1.19.10-r1 revbump to normalize vendor packages (diff)
downloadgentoo-2a78e7f1bfd34a0f1ac7710725077999c06805e0.tar.gz
gentoo-2a78e7f1bfd34a0f1ac7710725077999c06805e0.tar.bz2
gentoo-2a78e7f1bfd34a0f1ac7710725077999c06805e0.zip
media-libs/zxing-cpp: Fix build with GCC-11
Closes: https://bugs.gentoo.org/787560 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/zxing-cpp')
-rw-r--r--media-libs/zxing-cpp/files/zxing-cpp-1.1.1-gcc11.patch22
-rw-r--r--media-libs/zxing-cpp/zxing-cpp-1.1.1.ebuild4
2 files changed, 25 insertions, 1 deletions
diff --git a/media-libs/zxing-cpp/files/zxing-cpp-1.1.1-gcc11.patch b/media-libs/zxing-cpp/files/zxing-cpp-1.1.1-gcc11.patch
new file mode 100644
index 000000000000..13adad906c0d
--- /dev/null
+++ b/media-libs/zxing-cpp/files/zxing-cpp-1.1.1-gcc11.patch
@@ -0,0 +1,22 @@
+From 427e814ebcfd2e55e1c18531b7e4aa9d6a1ca6fc Mon Sep 17 00:00:00 2001
+From: Christophe Giboudeaux <christophe@krop.fr>
+Date: Tue, 9 Feb 2021 09:28:23 +0100
+Subject: [PATCH] Fix build with GCC 11
+
+Starting with GCC 11, the 'limits' header is not included transitively anymore.
+---
+ core/src/Pattern.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/core/src/Pattern.h b/core/src/Pattern.h
+index 4bbe6d26..c4a3f7c5 100644
+--- a/core/src/Pattern.h
++++ b/core/src/Pattern.h
+@@ -22,6 +22,7 @@
+ #include <cmath>
+ #include <cstddef>
+ #include <cstdint>
++#include <limits>
+ #include <numeric>
+ #include <vector>
+
diff --git a/media-libs/zxing-cpp/zxing-cpp-1.1.1.ebuild b/media-libs/zxing-cpp/zxing-cpp-1.1.1.ebuild
index a43d3881a651..3b38eb67cad9 100644
--- a/media-libs/zxing-cpp/zxing-cpp-1.1.1.ebuild
+++ b/media-libs/zxing-cpp/zxing-cpp-1.1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,6 +16,8 @@ IUSE="test"
RESTRICT="!test? ( test )"
+PATCHES=( "${FILESDIR}/${P}-gcc11.patch" )
+
src_configure() {
local mycmakeargs=(
-DBUILD_EXAMPLES=OFF # nothing is installed