summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-25 11:05:49 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-25 16:38:05 +0100
commit0a518ca277805005ec066b8de589147cc0482b97 (patch)
tree1554f3940aecb259d5c845895e516998d3a87284 /media-libs
parentnet-libs/xrootd-ceph: bump to 5.1.0 (diff)
downloadgentoo-0a518ca277805005ec066b8de589147cc0482b97.tar.gz
gentoo-0a518ca277805005ec066b8de589147cc0482b97.tar.bz2
gentoo-0a518ca277805005ec066b8de589147cc0482b97.zip
media-libs/freeglut: Switch to cmake.eclass, silence cmake warning
Add missing || die. Closes: https://bugs.gentoo.org/721006 Closes: https://bugs.gentoo.org/770547 Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/freeglut/freeglut-3.2.1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/media-libs/freeglut/freeglut-3.2.1.ebuild b/media-libs/freeglut/freeglut-3.2.1.ebuild
index 3ea22fc54f73..af9972f1c098 100644
--- a/media-libs/freeglut/freeglut-3.2.1.ebuild
+++ b/media-libs/freeglut/freeglut-3.2.1.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib
DESCRIPTION="A free OpenGL utility toolkit, the open-sourced alternative to the GLUT library"
@@ -32,6 +33,7 @@ HTML_DOCS=( doc/. )
src_configure() {
local mycmakeargs=(
+ "-DOpenGL_GL_PREFERENCE=GLVND" # bug 721006
"-DFREEGLUT_GLES=OFF"
"-DFREEGLUT_BUILD_DEMOS=OFF"
"-DFREEGLUT_BUILD_STATIC_LIBS=$(usex static-libs ON OFF)"
@@ -41,6 +43,6 @@ src_configure() {
}
multilib_src_install() {
- cmake-utils_src_install
- cp "${D}"/usr/$(get_libdir)/pkgconfig/{,free}glut.pc
+ cmake_src_install
+ cp "${D}"/usr/$(get_libdir)/pkgconfig/{,free}glut.pc || die
}