summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-06-08 10:29:56 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-06-08 10:29:56 +0200
commit0ffab1af371ae5fbcaad1a17e8708dfaec0eb85b (patch)
tree4084d3a0cfb1901f18fe8c4abf8853ca054a1b18 /media-libs
parentdev-java/rat: removed obsolete 0.11 (diff)
downloadgentoo-0ffab1af371ae5fbcaad1a17e8708dfaec0eb85b.tar.gz
gentoo-0ffab1af371ae5fbcaad1a17e8708dfaec0eb85b.tar.bz2
gentoo-0ffab1af371ae5fbcaad1a17e8708dfaec0eb85b.zip
media-libs/rubberband: bump to 1.9.2
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/rubberband/Manifest1
-rw-r--r--media-libs/rubberband/files/rubberband-1.9.2-build.patch180
-rw-r--r--media-libs/rubberband/rubberband-1.9.2.ebuild54
3 files changed, 235 insertions, 0 deletions
diff --git a/media-libs/rubberband/Manifest b/media-libs/rubberband/Manifest
index 844ba70b6595..169c9bbc1014 100644
--- a/media-libs/rubberband/Manifest
+++ b/media-libs/rubberband/Manifest
@@ -1 +1,2 @@
DIST rubberband-1.9.1.tar.bz2 164644 BLAKE2B 1bbbd0056b2131ac16bf427db93e19bdd6adb5433733e62523f4a04c8a74d1a48e82dbace09e7ffe6dddfeec699e3aeee8e84344c9e7cbe75067316dde6268d6 SHA512 cb20ef8fb717a9e6b5b0b921541bd701e94326e12cdb20d50bed344d12fa1b4fd731335c3a0a7f2d2a5ce96031d965b209e7667c4d55fd8494b8e20d3409f0d3
+DIST rubberband-1.9.2.tar.bz2 164178 BLAKE2B dc8e5b4c773dbb5c556331fa56e6cf4a5dd3f8a0fc7dcfed1fbe53d1a7635f12db6a884e775fbff8022e252d98b4e14a46a2395a5d4cb7645522ddf3e6b5482f SHA512 b1c763ab2a428aa2f1f8e5d0be6e9eb669808059ee5389e94f12de25f1a05cd89022656d98906c90b616773da11ab1f596ae2c5a9d300118e88049e1443121f2
diff --git a/media-libs/rubberband/files/rubberband-1.9.2-build.patch b/media-libs/rubberband/files/rubberband-1.9.2-build.patch
new file mode 100644
index 000000000000..dea90db4ddb0
--- /dev/null
+++ b/media-libs/rubberband/files/rubberband-1.9.2-build.patch
@@ -0,0 +1,180 @@
+diff --git a/meson.build b/meson.build
+index 3f7218c..3d402de 100644
+--- a/meson.build
++++ b/meson.build
+@@ -97,17 +97,25 @@ endforeach
+
+ fftw3_dep = dependency('fftw3', version: '>= 3.0.0', required: false)
+ samplerate_dep = dependency('samplerate', version: '>= 0.1.8', required: false)
+-sndfile_dep = dependency('sndfile', version: '>= 1.0.16', required: false)
+-vamp_dep = dependency('vamp-sdk', version: '>= 2.9', required: false)
++if get_option('programs')
++ sndfile_dep = dependency('sndfile', version: '>= 1.0.16', required: false)
++endif
++if get_option('vamp')
++ vamp_dep = dependency('vamp-sdk', version: '>= 2.9', required: false)
++endif
+ thread_dep = dependency('threads')
+-have_ladspa = cpp.has_header('ladspa.h', args: extra_include_args)
++if get_option('ladspa')
++ have_ladspa = cpp.has_header('ladspa.h', args: extra_include_args)
++endif
+ have_sincos = cpp.has_function('sincos',
+ prefix: '#define _GNU_SOURCE\n#include <math.h>',
+ args: '-lm')
+-have_jni = cpp.has_header('jni.h', args: extra_include_args)
++if get_option('jni')
++ have_jni = cpp.has_header('jni.h', args: extra_include_args)
+
+-javac = find_program('javac', required: false)
+-jar = find_program('jar', required: false)
++ javac = find_program('javac', required: false)
++ jar = find_program('jar', required: false)
++endif
+
+
+ # Check FFT and resampler options and set up dependencies and paths
+@@ -273,37 +281,41 @@ if ipp_needed
+ endif
+ endif # ipp_needed
+
+-if not vamp_dep.found()
+- vamp_dep = cpp.find_library('VampPluginSDK',
+- dirs: get_option('extra_lib_dirs'),
+- has_headers: ['vamp-sdk.h'],
+- header_args: extra_include_args,
+- required: false)
++if get_option('vamp')
+ if not vamp_dep.found()
+- vamp_dep = cpp.find_library('vamp-sdk',
++ vamp_dep = cpp.find_library('VampPluginSDK',
+ dirs: get_option('extra_lib_dirs'),
+ has_headers: ['vamp-sdk.h'],
+ header_args: extra_include_args,
+ required: false)
++ if not vamp_dep.found()
++ vamp_dep = cpp.find_library('vamp-sdk',
++ dirs: get_option('extra_lib_dirs'),
++ has_headers: ['vamp-sdk.h'],
++ header_args: extra_include_args,
++ required: false)
++ endif
+ endif
++ have_vamp = true
+ endif
+-have_vamp = vamp_dep.found()
+-
+-if not sndfile_dep.found()
+- sndfile_dep = cpp.find_library('sndfile',
+- dirs: get_option('extra_lib_dirs'),
+- has_headers: ['sndfile.h'],
+- header_args: extra_include_args,
+- required: false)
++
++if get_option('programs')
+ if not sndfile_dep.found()
+- sndfile_dep = cpp.find_library('sndfile-1',
++ sndfile_dep = cpp.find_library('sndfile',
+ dirs: get_option('extra_lib_dirs'),
+ has_headers: ['sndfile.h'],
+ header_args: extra_include_args,
+ required: false)
++ if not sndfile_dep.found()
++ sndfile_dep = cpp.find_library('sndfile-1',
++ dirs: get_option('extra_lib_dirs'),
++ has_headers: ['sndfile.h'],
++ header_args: extra_include_args,
++ required: false)
++ endif
+ endif
++ have_sndfile = true
+ endif
+-have_sndfile = sndfile_dep.found()
+
+
+ # General platform and compiler expectations
+@@ -404,8 +416,10 @@ endif
+ # And the build targets: Static and dynamic libraries, command-line
+ # utility, LADSPA plugin, Vamp plugin, JNI library
+
+-message('Will build Rubber Band Library static library')
+-target_summary += { 'Static library': [ true, 'Name: ' + rubberband_static_name ] }
++if get_option('static')
++ message('Will build Rubber Band Library static library')
++ target_summary += { 'Static library': [ true, 'Name: ' + rubberband_static_name ] }
++endif
+ rubberband_static = static_library(
+ rubberband_static_name,
+ library_sources,
+@@ -443,7 +457,7 @@ else
+ message('Not building Rubber Band Library dynamic library: no_shared option set')
+ endif
+
+-if have_jni and javac.found() and jar.found()
++if get_option('jni')
+ target_summary += { 'JNI library': [ true, 'Name: ' + rubberband_jni_name ] }
+ message('Will build Java Native Interface')
+ rubberband_jni = shared_library(
+@@ -478,7 +492,7 @@ if have_jni and javac.found() and jar.found()
+ )
+ else
+ target_summary += { 'JNI library': false }
+- if not have_jni
++ if not get_option('jni')
+ message('Not building Java Native Interface: jni.h header not found')
+ else
+ message('Not building Java Native Interface: Java compiler not found')
+@@ -492,7 +506,7 @@ install_headers(
+ subdir: 'rubberband'
+ )
+
+-if have_ladspa
++if get_option('ladspa')
+ target_summary += { 'LADSPA plugin': [ true, 'Name: ' + rubberband_ladspa_name ] }
+ message('Will build LADSPA plugin')
+ rubberband_ladspa = shared_library(
+@@ -527,7 +541,7 @@ else
+ message('Not building LADSPA plugin: ladspa.h header not found')
+ endif
+
+-if have_vamp
++if get_option('vamp')
+ target_summary += { 'Vamp plugin': [ true, 'Name: ' + rubberband_vamp_name ] }
+ message('Will build Vamp plugin')
+ rubberband_vamp = shared_library(
+@@ -559,7 +573,7 @@ else
+ message('Not building Vamp plugin: Vamp dependency not found')
+ endif
+
+-if have_sndfile
++if get_option('programs')
+ target_summary += { 'Command-line utility': [ true, 'Name: ' + rubberband_program_name ] }
+ message('Will build command-line utility')
+ rubberband_program = executable(
+diff --git a/meson_options.txt b/meson_options.txt
+index 86bf686..b99bb38 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -31,3 +31,22 @@ option('no_shared',
+ value: 'false',
+ description: 'Do not build shared libraries. On Windows this will also ensure that the static library is called simply rubberband.lib, not rubberband-static.lib as it is in the default build.')
+
++option('jni',
++ type: 'boolean',
++ value: 'false')
++
++option('ladspa',
++ type: 'boolean',
++ value: 'false')
++
++option('programs',
++ type: 'boolean',
++ value: 'false')
++
++option('static',
++ type: 'boolean',
++ value: 'false')
++
++option('vamp',
++ type: 'boolean',
++ value: 'false')
diff --git a/media-libs/rubberband/rubberband-1.9.2.ebuild b/media-libs/rubberband/rubberband-1.9.2.ebuild
new file mode 100644
index 000000000000..f390295a8a94
--- /dev/null
+++ b/media-libs/rubberband/rubberband-1.9.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson-multilib
+
+DESCRIPTION="An audio time-stretching and pitch-shifting library and utility program"
+HOMEPAGE="https://www.breakfastquay.com/rubberband/"
+SRC_URI="https://breakfastquay.com/files/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ladspa jni static-libs +programs vamp"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+CDEPEND="
+ media-libs/libsamplerate[${MULTILIB_USEDEP}]
+ sci-libs/fftw:3.0[${MULTILIB_USEDEP}]
+ jni? ( >=virtual/jdk-1.8:* )
+ ladspa? ( media-libs/ladspa-sdk )
+ programs? ( media-libs/libsndfile )
+ vamp? ( media-libs/vamp-plugin-sdk[${MULTILIB_USEDEP}] )
+"
+RDEPEND="${CDEPEND}"
+DEPEND="${CDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-build.patch"
+)
+
+multilib_src_configure() {
+ local emesonargs=(
+ --buildtype=release
+ -Dfft=fftw
+ -Dresampler=libsamplerate
+ $(meson_use static-libs static)
+ $(meson_use ladspa)
+ $(meson_use jni)
+ $(meson_use programs)
+ $(meson_use vamp)
+ )
+ use jni && emesonargs+=(
+ -Dextra_include_dirs="$(java-config -g JAVA_HOME)/include,$(java-config -g JAVA_HOME)/include/linux"
+ )
+ meson_src_configure
+}
+
+multilib_src_install_all() {
+ ! use jni && find "${ED}" -name "*.a" -delete
+}