summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-05-27 14:27:18 -0400
committerMichael Orlitzky <mjo@gentoo.org>2023-05-27 18:01:24 -0400
commit1febf678d8ed530256baf273d851a0227cc7db61 (patch)
treedb25c71be3b2e60ac1d0310f09a8a6e1c217cc85 /media-libs
parentnet-misc/gallery-dl: bump to 1.25.5 (diff)
downloadgentoo-1febf678d8ed530256baf273d851a0227cc7db61.tar.gz
gentoo-1febf678d8ed530256baf273d851a0227cc7db61.tar.bz2
gentoo-1febf678d8ed530256baf273d851a0227cc7db61.zip
media-libs/libnsgif: add 9999
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libnsgif/libnsgif-9999.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/libnsgif/libnsgif-9999.ebuild b/media-libs/libnsgif/libnsgif-9999.ebuild
new file mode 100644
index 000000000000..53cb45fba3c3
--- /dev/null
+++ b/media-libs/libnsgif/libnsgif-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit git-r3 netsurf
+
+DESCRIPTION="decoding library for the GIF image file format, written in C"
+HOMEPAGE="https://www.netsurf-browser.org/projects/libnsgif/"
+
+EGIT_REPO_URI="https://git.netsurf-browser.org/${PN}.git"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+BDEPEND="
+ dev-util/netsurf-buildsystem
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+}
+
+_emake() {
+ netsurf_define_makeconf
+ emake "${NETSURF_MAKECONF[@]}" COMPONENT_TYPE=lib-shared $@
+}
+
+src_compile() {
+ _emake
+}
+
+src_install() {
+ _emake DESTDIR="${D}" install
+}