summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2021-03-31 02:00:55 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-04-11 11:08:46 +0300
commit20d7445cd5b4a81684ba19e5d73249da309dc022 (patch)
treec1f0ea06dc4c9b60df0d13df66a7eba323858a2e /media-libs
parentmedia-gfx/gimp: live ebuild update (diff)
downloadgentoo-20d7445cd5b4a81684ba19e5d73249da309dc022.tar.gz
gentoo-20d7445cd5b4a81684ba19e5d73249da309dc022.tar.bz2
gentoo-20d7445cd5b4a81684ba19e5d73249da309dc022.zip
media-libs/gegl: Remove '-Dgraphviz=disable' option
The media-gfx/graphiz is runtime checking for gegl(gegl::introcpect). As example this feature is optionally used at runtime as gegl feature of gimp menu "File - Debug - Show Image Graph" if graphviz is presented in system for >=media-gfx/gimp-2.99.4[debug]. Add optfeature.eclass log message. Closes: https://bugs.gentoo.org/758860 Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/20206 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gegl/gegl-0.4.30.ebuild9
-rw-r--r--media-libs/gegl/gegl-9999.ebuild9
2 files changed, 10 insertions, 8 deletions
diff --git a/media-libs/gegl/gegl-0.4.30.ebuild b/media-libs/gegl/gegl-0.4.30.ebuild
index 5835159e6074..e99fb1c28e19 100644
--- a/media-libs/gegl/gegl-0.4.30.ebuild
+++ b/media-libs/gegl/gegl-0.4.30.ebuild
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python3_{7..9} )
# vala and introspection support is broken, bug #468208
VALA_USE_DEPEND=vapigen
-inherit meson gnome2-utils python-any-r1 vala
+inherit meson gnome2-utils optfeature python-any-r1 vala
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -121,9 +121,6 @@ src_configure() {
-Ddocs=false
-Dexiv2=disabled
-Dgdk-pixbuf=enabled
- # - There are two checks for dot, one controllable by --with(out)-graphviz
- # which toggles HAVE_GRAPHVIZ that is not used anywhere. Yes.
- -Dgraphviz=disabled
-Djasper=disabled
# - libspiro: not in portage main tree
-Dlibspiro=disabled
@@ -156,3 +153,7 @@ src_configure() {
)
meson_src_configure
}
+
+pkg_postinst() {
+ optfeature "'Show Image Graph' under GIMP[debug] menu 'File - Debug'" media-gfx/graphviz
+}
diff --git a/media-libs/gegl/gegl-9999.ebuild b/media-libs/gegl/gegl-9999.ebuild
index 234914ee6fa1..31e6ad02e66d 100644
--- a/media-libs/gegl/gegl-9999.ebuild
+++ b/media-libs/gegl/gegl-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{7..9} )
VALA_USE_DEPEND=vapigen
-inherit meson gnome2-utils python-any-r1 vala
+inherit meson gnome2-utils optfeature python-any-r1 vala
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -111,9 +111,6 @@ src_configure() {
-Ddocs=false
-Dexiv2=disabled
-Dgdk-pixbuf=enabled
- # - There are two checks for dot, one controllable by --with(out)-graphviz
- # which toggles HAVE_GRAPHVIZ that is not used anywhere. Yes.
- -Dgraphviz=disabled
-Djasper=disabled
# - libspiro: not in portage main tree
-Dlibspiro=disabled
@@ -146,3 +143,7 @@ src_configure() {
)
meson_src_configure
}
+
+pkg_postinst() {
+ optfeature "'Show Image Graph' under GIMP[debug] menu 'File - Debug'" media-gfx/graphviz
+}