summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-21 21:29:20 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-21 21:29:45 +0200
commit243856f76077e7d73c1714b410b538de9cd71dc6 (patch)
tree27c939f36c2434c5701e1d0a5f3477cd34602104 /media-libs
parentmedia-libs/zimg: EAPI-7 bump (diff)
downloadgentoo-243856f76077e7d73c1714b410b538de9cd71dc6.tar.gz
gentoo-243856f76077e7d73c1714b410b538de9cd71dc6.tar.bz2
gentoo-243856f76077e7d73c1714b410b538de9cd71dc6.zip
media-libs/zimg: Sync live with 2.7.5 changes
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/zimg/zimg-9999.ebuild35
1 files changed, 15 insertions, 20 deletions
diff --git a/media-libs/zimg/zimg-9999.ebuild b/media-libs/zimg/zimg-9999.ebuild
index fe1991fc9e05..62adc665df35 100644
--- a/media-libs/zimg/zimg-9999.ebuild
+++ b/media-libs/zimg/zimg-9999.ebuild
@@ -1,36 +1,31 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-AUTOTOOLS_AUTORECONF=yes
-
-SCM=""
-
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
+if [[ ${PV} = *9999* ]] ; then
EGIT_REPO_URI="https://github.com/sekrit-twc/zimg"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/sekrit-twc/zimg/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+ S="${WORKDIR}/${PN}-release-${PV}/"
fi
-
-inherit autotools-multilib ${SCM}
+inherit autotools multilib-minimal
DESCRIPTION="Scaling, colorspace conversion, and dithering library"
HOMEPAGE="https://github.com/sekrit-twc/zimg"
-if [ "${PV#9999}" = "${PV}" ] ; then
- SRC_URI="https://github.com/sekrit-twc/zimg/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
- S="${WORKDIR}/${PN}-release-${PV}/"
-fi
-
LICENSE="WTFPL-2"
SLOT="0"
IUSE="static-libs cpu_flags_x86_sse"
-DEPEND=""
-RDEPEND="${DEPEND}"
+src_prepare() {
+ default
+ eautoreconf
+}
-src_configure() {
- autotools-multilib_src_configure \
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
$(use_enable cpu_flags_x86_sse x86simd)
}