summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-10-11 21:39:20 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-10-11 23:32:53 +0200
commit2eaabc8ed574ba18a913845fcf6d987d8a2a05ff (patch)
tree3c68bfc3c10449b557d50192c228e45ed1f4d6df /media-libs
parentkde-apps/lokalize: Drop kde-apps/kross-interpreters from RDEPEND (diff)
downloadgentoo-2eaabc8ed574ba18a913845fcf6d987d8a2a05ff.tar.gz
gentoo-2eaabc8ed574ba18a913845fcf6d987d8a2a05ff.tar.bz2
gentoo-2eaabc8ed574ba18a913845fcf6d987d8a2a05ff.zip
media-libs/zxing-cpp: Disable examples build, add IUSE="test"
Closes: https://bugs.gentoo.org/747841 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/zxing-cpp/zxing-cpp-1.1.1.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/media-libs/zxing-cpp/zxing-cpp-1.1.1.ebuild b/media-libs/zxing-cpp/zxing-cpp-1.1.1.ebuild
index f31cea8e8ba1..cd5a24f0ab97 100644
--- a/media-libs/zxing-cpp/zxing-cpp-1.1.1.ebuild
+++ b/media-libs/zxing-cpp/zxing-cpp-1.1.1.ebuild
@@ -12,4 +12,14 @@ SRC_URI="https://github.com/nu-book/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
-IUSE=""
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_EXAMPLES=OFF # nothing is installed
+ -DBUILD_BLACKBOX_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}