summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-04-14 23:52:40 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-04-15 17:11:21 +0200
commit322a8b71a31ccb00c962ee5991e1aea5d06cdcfc (patch)
treeaf68c2202d94a5a4211ffb3d967daf8f198fb5d8 /media-libs
parentmedia-libs/lcms: Fix USE=static-libs (diff)
downloadgentoo-322a8b71a31ccb00c962ee5991e1aea5d06cdcfc.tar.gz
gentoo-322a8b71a31ccb00c962ee5991e1aea5d06cdcfc.tar.bz2
gentoo-322a8b71a31ccb00c962ee5991e1aea5d06cdcfc.zip
media-libs/lcms: Drop unused eutils.eclass, unused zlib RDEPEND
Indeed ZLIB is nowhere used. Cleanup outdated blocker, do some sorting. Gentoo-bug: 609294 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/lcms/lcms-2.8-r2.ebuild25
1 files changed, 10 insertions, 15 deletions
diff --git a/media-libs/lcms/lcms-2.8-r2.ebuild b/media-libs/lcms/lcms-2.8-r2.ebuild
index bca90ecc304e..5f5522eabafe 100644
--- a/media-libs/lcms/lcms-2.8-r2.ebuild
+++ b/media-libs/lcms/lcms-2.8-r2.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-AUTOTOOLS_PRUNE_LIBTOOL_FILES="modules"
-inherit eutils multilib-minimal
+
+inherit multilib-minimal
DESCRIPTION="A lightweight, speed optimized color management engine"
HOMEPAGE="http://www.littlecms.com/"
@@ -12,30 +12,25 @@ SRC_URI="mirror://sourceforge/${PN}/lcms2-${PV}.tar.gz"
LICENSE="MIT"
SLOT="2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc jpeg static-libs +threads test tiff zlib"
+IUSE="doc jpeg static-libs test +threads tiff"
-RDEPEND="jpeg? ( >=virtual/jpeg-0-r2:0[${MULTILIB_USEDEP}] )
+RDEPEND="
+ jpeg? ( >=virtual/jpeg-0-r2:0[${MULTILIB_USEDEP}] )
tiff? ( >=media-libs/tiff-4.0.3-r6:0=[${MULTILIB_USEDEP}] )
- zlib? ( >=sys-libs/zlib-1.2.8-r1:=[${MULTILIB_USEDEP}] )
- abi_x86_32? (
- !<=app-emulation/emul-linux-x86-baselibs-20130224-r10
- !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
- )"
+"
DEPEND="${RDEPEND}"
-S=${WORKDIR}/lcms2-${PV}
+S="${WORKDIR}/lcms2-${PV}"
-PATCHES=(
- "${FILESDIR}/${P}-CVE-2016-10165.patch"
-)
+PATCHES=( "${FILESDIR}/${P}-CVE-2016-10165.patch" )
multilib_src_configure() {
local myeconfargs=(
$(use_with jpeg)
$(use_enable static-libs static)
- $(use_with tiff)
- $(use_with zlib)
$(use_with threads)
+ $(use_with tiff)
+ --without-zlib
)
ECONF_SOURCE="${S}" \
econf ${myeconfargs[@]}